Why is it blurry?

I can’t do much with blender yet. I can make a basic object move. That’s about it. But when I do that and play it back the edges are blurry and almost choppy and it makes my eyes go crazy. I noticed that in some of Neil Hirsig’s video tutorials the same thing happens. I’ve seen many blender animations here and on the net and I don’t see this problem. Why is that? How can I fix it?

Thanks.

Very nice resource - thank you. ------ Gray (Retro Jordans).

Can you show or link to examples that demonstrate the good and bad results?

Hi,

Disable the Fields button, if you’ve pressed it accidentally.

No. I don’t have any examples available right now. I use my pc for my personal stuff and I use somebody else’s pc for the internet. I’ll have to see if I can transfer something to here and upload it somewhere. All I have to do is just make a cube or something and put it in motion.

Rawpigeon, thanks for the suggestion. I’ll see if I can find the fields button and give that a try later tonight. I’ll let you know if it helps.

The fields button didn’t do anything.

Hi,

Have you enabled motion blur (MBlur)?

I don’t know what that is or where to find it. I just go into Blender and add a mesh object, in this case a square and make it into a rectangle, and make it move, and it gets blurry on the edges when I play back the rendered version, particularly at the back end of the object. I’m not switching anything or clicking any other buttons,

I’m so confoozed! :spin: LOL.

Hi,

Can you post a screenshot of your render settings? You might be rendering your animation to a low quality, lossy format and seeing compression artifacts.

My stuff is on my pc and I use somebody else’s pc to use the internet. I have to see if I can transfer things like this and then figure out how to post stuff here.

How do you just get a screenshot of render settings? I’m sorry, but I’m new to all this.

And if what you suggested is correct, how do I fix it?

Thanks for your help.

Hi,

Here’s a good page that explains what I mentioned:

http://wiki.blender.org/index.php/Manual/Output_Formats

Most of the animation formats (e.g. AVI Jpeg, FFMpeg) are lossy formats and reduce the amount of information in the pictures to reduce the file size. Depending on the exact format and settings, the loss of information may be subtle enough that you don’t notice it or it might result in noticeable artifacts, like blurring, blockiness and strange colour streaking.

For long or complex animations, many people will not render directly to an animation format, but to a series of stills using a lossless format (e.g. png). This gives you much more flexibility for a number of reasons:

  • You don’t need to render the entire animation at once.
  • You can easily postprocess your rendered frames before assembling them into an animation.
  • If your assembled animation suffers from compression artifacts, you can just change some settings and reassemble the pre-rendered frames - you don’t need to re-render the entire scene.

Of course, this may not be the problem at all :slight_smile:

Hope this helps, but my apologies if you already knew all of it.

I didn’t know any of that. I don’t know much yet. I’m still a Blender Baby. :smiley:

Thanks for the info and the link. I’ll look more into it later.

It all is kind of confusing to me right now. I’m going to make an animation of what I’m talking about and see if I can transfer it to this pc and upload it. I just opened a YouTube account. I’ll see if I can put it up there.

I’ve uploaded a video to YouTube.

It doesn’t look as clear on YouTube. On my pc, the edges are more defined, but they get blurry or shaky. On YouTube, it’s a little more fuzzy.

That’s exactly what RawPigeon was telling you…it’s jpeg compression (yuk). Codecs suck but if you have to use one when rendering as opposed to rendering individual, lossless frames as suggested then use Quicktime’s “Animation” codec which is lossless although not very compressive. Whatever you decide make sure you always have the “Quality” setting on the out put tab set to 100% when doing your initial render. That way you can always go back and adjust the quality of the rendered file(s) to taste via the sequence editor or compositor although this is almost a moot point with such a simplistic scene.

I uploaded another verson of the animation. The box is moving straight across the screen and the camera is not tracking it. It seem worse than the first angle with the camera tracking it.

And after examining the first angle more, I noticed the blurry shaky effect is more noticable on the left top edge of the box as it is moving across the camera while the camera is turning to track it. But it doesn’t seem as bad on the pc I’m using for the internet. It seems to be worse on my pc, which is older. I got it about 6 years ago.

Does anybody see any problems that may be corrected when viewing the animations on YouTube? Or could my older pc be the problem?

Older monitors become progressiverly more blurry as they age. Adjusting the refresh rate can help stabilize (somewhat) some of that blurriness.

Thanks RamboBaby.

I didn’t know there was a quality setting.

And some of the terminologies being used for this animation stuff are new and confusing to me, like post process, sequence editor, compositor, the different file types, etc.

I’m also trying to understand the process that Rawpigeon mentioned earlier for rendering stills instead of directly to an animation format. Does this take longer, and how do you do it?

Older monitors become progressiverly more blurry as they age. Adjusting the refresh rate can help stabilize (somewhat) some of that blurriness.

How do you adjust the refresh rate? Is that a Blender option or something on my pc?

(windoze) Controll pannel>Appearance and Themes>Display>Settings>“Advanced” button>“Monitor” tab>“Screen Refresh Rate:” field.

Thanks Rambo. I’ll try it and see if it helps any.