Why is my .blend GROWING????

I’m running the “official” build of Blender 2.42a (from blender.org) for my Macintel iMac and am finding my .blend’s grow for no apparent reason. So I did some experimenting this morning, starting with an empty scene:

  • “Suzanne” with no texture, 212 KB
  • Subsurf level 2, 676 KB
  • Created new procedural texture, 676 KB
  • Ran “Self Shadow” script, 1.1 MB
  • Ran UV “Unwrap” script, 1.1 MB
  • Ran “Texture Bake” script, 7.7 MB
  • Changed texture from procedural to UV mapped texture, 16.6 MB
  • Changed texture from UV mapped texture to procedural, 25.9 MB

Yesterday my file size grew to 52 MB and only contained one 7,000 poly mesh! Any idea what’s going on and if there’s anything I can do to fix this???

Is it possible the images you created are packed along with the .blend file? How big were the images?

That’s what I was starting to think, but I didn’t select the “pack” menu option? I may try “unpack” and see what happens. The model only has 1 512x512 texture which, even if Blender is “packing” the file, shouldn’t be -that- big? I’m a bit new to Blender on a Mac, I’ve always used either Windows or Linux and never had this problem before…

UPDATE: I just tried “unpack data” and it replied that there was no data packed.

Here’s what I think is happening: I think “texture bake” creates temporary files and these are inadvertently being saved inside the .blend. The reason I think this is because I tried using BRrayBaker which I know creates lots of little bitmaps and saves them in a folder called “/temp”. When I ran BRrayBaker last week, it crashed but I never found all the temporary texture files it created. I hadn’t occurred to me then, but I’m that .blend was -huge- and I bet that’s the reason why. I don’t know, but I’m betting “texture bake” also creates temporary files that are being saved inside the .blend. If this is the case, then it sure looks like a bug.

Another update: I just changed the “/temp” folder setting in the paths settings and got the very same problems.

make a new blend then append the model to the new one with shift+f1

That works, got my .blend back down to 1 MB. That’ll get me going for now, but it sure is a paint to have to do…

BTW, I’m pretty sure this is a bug, where do we report bugs for Blender?

The Blender bug tracker, it’s in the Blender projects pages accessable from Blender.org

Thanks, I just finished submitting the bug report. Hope this one gets some attention in time for the next release…