Why is my eevee volumetric cloud so dark?

Above is an early version of my scene. From left to right there is the default blender plane with the default material, my custom volumetric cloud, and an element that I want to use in the scene. The lighting is an HDRI from HDRIHaven.com, and a sun lamp.

what I need is a brighter cloud material that matches the brightness of the plane and structure. I have played with all of the color and density settings, but nothing creates a brighter result than what I have above.

How to I make the cloud brighter?

here are my material settings:

Not really a correct solution, but coudn’t you cheat a bit and just add small amount of emission?

Try upping the number of volume bounces in the Render Settings --> light Paths screen (edit - this might not be possible if you are using Eevee not Cycles).

I have already tried this and it doesn’t help. All it affects is the darkest part of the cloud and not the highlights like I want.

Density to high/thick? High Density usally make dark clouds.Put a math multiply after the colorramp and try 0.10 - 0.30

Additional,you dont have to use a principled shader into the surface.Use only the volume shader into the volume.

The extinction in a cloud is 0.005 -0.1 m^-1
if your cloud model scale is in blender units (same scale as the real cloud) this is a good start.
Then the ext cofficient works for it self at density 1.

if you have cloud model with a size of 1m IE.And you want a optic of a cloud that is 10m thick,then you have to multiply the extinction,in this case with the density.for a 10m thick cloud optic then set the density to 10.

edit,further look at these cloud vdb rendering tests,and the volume bounce settings,to get a good basis for the scattering.

2 Likes