Why is my extrude dimension completely different ?

i created a curve and extruded it by 7 units. But on the Viewport and in the object dimensions it shows 12.116 Units.

How can i do this correct, so the dimension corresponds with the amount of extrusion ?


Double the curve extrude value and you’ll get the Z-dimension, maybe you have changed curve tilt values.

It does correspond. Extrude extrudes on both directions, so Dimensions panel value Y: 14.00 is the result of extruding by 7 units.

hm, i mean where the red arrow of the coordinate system goes, not sure which axis it represents right now, usually it would be x
but the dimensions sow 14 in y if you mean that. I count 12.something units in the view grid.

The curve seems standing 100% straight.

I have checked now with a 1 unit extrude and it comes also less than that. Maybe the coordinate system has a scale setting that is not directly visible in the preferences ?

When you extrude this way, it will extrude in both direction from the central axe. ( so 1.0 mean > 1+1 = 2 ) … So you need to divide the extrude lenght by 2 for end the right one.

If your bezier curve is finished, you can " convert it to mesh " then extrude it the standard way.

ok cool, working now :-))