Why is my Fluid Domain object visible? (cycles, Blender 2.65a)

Hi all,

Sorry if this is a stupid question:

I have made a fluid simulation, using an Offset value of -20 so that the fluid does not start to flow until 20 frames into the animation. However, now during the first 19 frames before the fluid sim kicks in, my fluid domain object is visible and blocks the camera from seeing anything inside that object. If I change the material of the domain object to 100% transparent, then this also changes the material of the fluid itself, which is not what I want.

How can I make the fluid domain object invisible, without also affecting the material of the fluid itself?

Here is the render at frame 19, before the fluid sim begins. The only thing visible is the domain object, reflecting the light from an emission plane behind and to the left of the camera:


Here is the render at frame 20, the first frame on which the fluid sim is calculated, with everything inside the fluid domain cube now visible (the fluid itself is still out of frame to the top):


Finally, here is the render later on, showing the fluid (with the same material as the domain object):


Thanks in advance for any suggestions,

Matt

Set it to be unrenderable in the outliner window (camera icon) ? You can keyframe this to be enabled/disabled.

Wow, your response came exactly 8 seconds after my post!

Unfortunately, unclicking the camera icon for the Fluid Domain object in outliner causes the fluid to not be rendered at all. For example, here is the corresponding frame (41) from my previous post, but now there’s no fluid in the render:


Thanks Richard,

Unfortunately, when I unselect the camera icon, the fluid itself does not get rendered. This is the render of the same frame (41) from my previous post, showing the result of unselecting the camera icon:


Ah Ha! You were right after all. The trick is to keyframe the object to not render until the fluid simulation starts, then render during the simulation. Problem solved.

Thanks!