Why Is My Game Sometimes All Weird?

So sometimes when I enter my game it looks like this: http://i1073.photobucket.com/albums/w399/CTapprich/blend_error_zpsc894e8a7.jpg

My graphics card is a Radeon X1400. Could that be the problem?

Oh, and here is what it’s supposed to look like: http://i1073.photobucket.com/albums/w399/CTapprich/game_normal_zps4f671741.jpg

Is the problem that certain faces aren’t showing up? Ensure that your normals face outwards correctly and you don’t have materials set to transparent unnecessarily. Also try triangulating N-Gon (faces that are composed from more than three or four vertices) faces manually (Ctrl+T with faces selected). It would appear that the BGE doesn’t always correctly convert these faces.

It’s not the normals, it’s the shading. It turns all weird and it’s really hard to explain but you should be able to see the difference in the images. I don’t know, but it’s kind of annoying.

Do you have any modifiers set on the room? If so, apply them. It might be helpful to post a blend file to help solve the issue.

Well I’m pretty sure it’s something with my computer. This isn’t the only file the BGE does this with. It’s either a Blender bug or my graphics card… I’m just hoping there’s a way to fix it.

I found a video on YouTube of someone having the same problem as me. He has a Radeon graphics card but seems to think it has to do with Windows 8, but I’m running Windows 7 and have the same problem so… Yeah.

Did you install the right and newest graphics card-driver for win7? (Just in case you haven’t done it.)

Since which version do you have the problem?
Did you tested newer builds from http://builder.blender.org/download/? Maybe the bug has been solved already.

Oh didn’t know there was a new version out. I’ll try it out.

All my drivers are up to date I’m pretty sure. I keep my eye on that stuff. :stuck_out_tongue:

You could also try changing the window draw type in the user preferences.

Okay, tried out the new version, and now when I enter the game, all the textures go away. -.- I’m going back to 2.64.

If you’re using UV images as textures (i.e. not materials) with Multitexture or Singletexture mode in the new Blender build, turn off material caching. I think it speeds loading up, but it requires each image to have its own material. If they don’t, it causes problems.

Actually, I downloaded the latest installer on the Blender site and it works fine now. There was something about just downloading the zip that messed it up. So far I haven’t seen any graphics bugs but I only just started using it so I’ll see.

Edit: Nope, still having the problem. But it occurs less now, so that’s good.