Why is my glass texture only transparent for the HDRI file but not the objects in my scene?

I followed a bunch of different glass tutorials on YouTube, but regardless of which one I used, the transparency only seems to work for the HDRI and not the objects in my scene.

I’ve tried it on all the different blend modes but to no avail. Although when on Alpha Blend my carpet becomes visible, but nothing else.

For transparency with the gass shader in Eevee you need to turn on refraction in you material settings and in the render settings.


Additionally, I’d take a look at the manual page that covers the specific way nodes (like the Glass BSDF node) are supported in Eevee:


And the limitations of Eevee regarding screen space refraction: