Why is my green screen footage blocking out lights in the scene, nor showing the proper color?

Hi! I have green screen footage that was chroma keyed, color corrected / graded, and exported in DaVinci Resolve (a video editor). To get it right, I matched my footage to a still image of a scene I made in Blender that’s using Cycles. And in DaVinci the footage is perfectly matched.

So I export that footage with a transparent background. The only thing not transparent is the person in the center. And the goal is to add this to the Blender scene so I can make it look more real by taking advantage of the Blender camera’s aperture, and the shadows that green screen footage can give when lighting is on it (shadows cast on walls, etc). I am using Cycles for all of this.

But when I load the footage in the scene, it blocks certain volumetric lights (but allows 1 in the center), and it doesn’t have the same color like when I exported it from DaVinci Resolve. The footage object is either too dark, or too bright, depending on the shading option I used when adding an Image As Plane (Principled BSDF, Shadeless, and Emit). Here’s an example:

  • Notice how the footage lets the volumetric lighting on the door pass through as it should, but not the windows on the left or right, even though the only object that should block it is what’s circled in green?

  • And how can I get my green screen object to be the color I made it as? I changed the color space of the object in the shading tab to RAW, and every other option, but none of these work as I’d expect.

  • I also tried adding extra lights to my footage in the scene, but that seems like a very inefficient way to do all this.

What is the most efficient way to go about this? Or is there some course that speaks about matching green screen shots to Blender scenes? All I’ve seen is surface level stuff that never deals with these sorts of problems.

1 Like

what shadow mode do you have this set as?
image

wrt the incorrect colors, images as planes just slaps that image in a principled bsdf, so you’ll need to check the color space, specularity etc etc, or just put it as a 1.000 strength emissive

Thanks for responding!

And I figured out the volumetric lighting problem, but not the color of the footage yet.

How I fixed the volumetric lighting problem: I’m not sure if Blender is just bugged or what… But the glass had a volume scatter object with light passing through it from the outside (intentional). And when my Image As Plane was put in front of it as the image shows, the volume scatter wouldn’t let light through. Turning it off made it work fine. No idea why. Looks just as good so I’m okay with it.

But the color problem remains on the Image As Plane object. I’m using Cycles too, so I don’t have those options (those are Eevee only). Here’s what I Have in Properties → Material Properties → Settings

Pass Index = 0
Surface → Multiple Importance = On
Surface → Transparent Shadows = On
Surface → Displacement = Bump Only
Volume → Sampling = Greyed out
Volume → Interpolation = Linear
Volume → Homogenous = Off
Volume → Step Rate = 1.0

Here’s the image as it is now vs what it should look like. Notice how it’s very flat?

I exported that footage from DaVinci. It’s looks exactly as it should in there, and anywhere else I watch it. But importing it into Blender makes it very flat. I’ve also played with the Color Space on the node, all the options on the BSDF, and added in a MixRGB to make it look better than it was, but nothing seems to be working.

If I can get the guy’s color on the left to look like the right, I’d be very happy. The rest of the scene doesn’t matter. Just the guy does. Any ideas?

its being affected by the lighting in the scene, if you want it to match 100%, you can do a few things. make an emission node, mix with transparent, using alpha as the mix factor, or do another render layer w/ everything as a holdout and composite later

I added it as an emission node and it works. Thanks you very much. I’ve been stuck on this for too long.

I suspect the reason the color wasn’t working before is because I copied / pasted the same thing, and it may have been sharing the same material settings as the previous one I was testing on.