Why is my mesh glitchy? On LinuxMint?

<<<< Why is this is happening? I just installed Linux Mint 17. And my Nvidia GeForce GTX 760 1.5GB is not set up yet with proper drivers. Is that the reason? Or could there be other reasons for this?

Dose anyone know how to set up propriety Nvida drivers for linux? I want to enable GPU CUDA.

For proper NVIDIA intallation and usage check this post http://forums.linuxmint.com/viewtopic.php?f=59&t=193160!
I’m also on Linux Mint 17.1, I followed it step by step and it works just fine!

Try installing the nvidia driver.
For a user friendly distribution like Mint, nvidia driver should be installed correctly just by selecting it from driver manager, without uninstalling/blacklist nouveau or do anything manually. So if it is not, you should report the problem to those responsible for the distribution.
After install the nvidia driver, just remember install the “nvidia-modprobe” package.
Also, to use CUDA in blender you don’t need install CUDA toolkit. You simply use official Blender tar.bz2 file, extract to a folder and run the “blender” file. That link that refers to the GTX960 can be related to the version of Blender in that date not yet included precompiled CUDA kernel for 9xx series. But if you download Blender from official Blender website, you should have no problems.

I don’t know if that’s 9xx specific but on both my machines with GT430 and GTX650 Bblender didn’t detected any GPU, with the drivers from Mints proprietary driver menu.

What worked was only what I likned to.

Also when I tried to install “nvidia-modprobe” all I got was “Unable to locate package nvidia-modprobe”

If you have any luck on YAFUs method i’d like to know.

Good Luck

In Ubuntu “nvidia-modprobe” is in the repositories (backports in 14.04). Otherwise you can search in internet the .deb package and install it, for example from “Ubuntu Packages” web site:

And you remember to use the Blender version downloaded from the Blender website.

At first I only used official release builds from Blender site.

Then I wrote a scipt (that can be found somewere in this forum) that automatically downloads and installs (basically extracts) the latest build from buildbot. And I kept both just in case I had any stability issues.

Now I only use everyday builds and I download the stable release if something goes extremely wrong.

Also why do I need “nvidia-modprobe” since “lsmod” spits back nvidia as the currently running driver.

Are you (YAFU) using Mint or another Distro? I’d like to know since I’m thinking of moving to Arch based distro.

If anybody else that are on Linux and YAFUs method is working please report …maybe the problem is my system…

I use Kubuntu 14.04.
I can assure you that in Ubuntu family (I don’t know in Mint) all that is needed is: Install the nvidia driver. Install “nvidia-modprobe” package (then reboot the system). Use official Blender, for CUDA work without having installed CUDA Toolkit.
Search this in google:

site:blenderartists.org “nvidia-modprobe”

Do you use Mint based on Ubuntu or Debian? Anyway, I guess that in Debian is the same.

Linux Mint is advertised as one of the easiest to use distributions. If Mint users have problems in installing the nvidia driver then should report the problem. Install the nvidia driver should be “easy”.

@YAFU. You’re totally right my friend. Just downloaded “nvidia-modprobe” and everything works fine.
I also now I know what “nvidia-modprobe” does.

For every one else consider my solution far more complicated and not really needed.

Hi CorsaiRally, you really have to test all settings, there is no rule for it.
Better is to get Nvidia driver to work.
Is it on every file? If not upload the .blend we can have a look.

Cheers, mib

I want to say thank you for everyone, who helped me!!! :slight_smile: Following the instructions with modprobe/cuda/nvidia thing worked. I now have GPU available in blender and that screen tearing has stopped!!! Thank you :slight_smile: