Why is my plane flat after displacement

Hey! take a look at this (im not experienced)

What did i do wrong? why is my plane still flat? thanks!

need to render to see the displacement.

i enabled render view with “z” but i see nothing :confused:

You need displacemt true and linnely you’ll want adaptive subdivision as last modifier (maybe its still experimental)

I dont see where to change displacement to true, and i subdivided my plane manually as you can see, i think it does the same thing no?

ohh i needed to enable experimental in cycles