Why is the bake tab missing on the render panel in 2.82?

Answer: You’re using the OptiX render device, which does not support baking.
Set it to any other in Preferences > System > Cycles Render Devices

Hope this helps someone sometime, this question spun me around for a good fifteen minutes :sweat_smile: