why is the liquid in my bottle black?

I’ve been trying various things, including adding photon lights, area lights, even changing the material colors.

But, I cannot figure out what I’m doing wrong here.

A- The liquid is coming out black when its seen through the glass, but should be closer to the amber color as seen over the rim of the cup.

B- weird black refelctions, I would have thought were because the world environment had lots of black within it. But, I am using the kitchen HDR file, which mostly has light colors and woodgrains. So I assume this is not coming from the world environment.

C- Applying the label directly to the bottle wouldnt work (for me) so I applied it to a plane, and positioned it on the bottle where a label should go. I set the material to transparent, and used two material textures one to apply the image affecting the Alpha value, and the second to apply the image as color. But, I couldnt get the grey area of the backgroumd plane to disapper with this technique.

D- And finallly, the label itself appears to have lost, or inverted all its white and black characteristics.

http://img310.imageshack.us/img310/6254/liquidcolorproblem5nf.jpg

Oh, in case it makes a great difference in how I go about fixing this… I’m using Blender 2.40, and Yafray 0.0.8

Because the Raytrace Depth is not high enough, increase the value in the Yafray settings (Second tab) or in the Ray Transp of the Mirror Transp tab if you are using internal render engine.

I remember seeing something like this before. It was in a bathroom that someone made. In the mirror, the reflection of a door handle was all black. I don’t know what it’s called or were it is. But, it’s somewere in this site.

Also, if you didn’t know, YafRay had a little problem with OpenEXR and threading on the windows compilation. So you might need to get a new one called YafRay installer 0.0.8-2.

Or you can change the bottle…

Blavod! the first BLACK Vodka…

Ahh, more evil fiends, now I must reopen Blender to answer more noobish questions! :<

But, again, I was there (here) no more than a month ago.

In the Materials tab, under Mirror Transp you will see a button: “Ray Mirror,” make sure that is pressed. Directly under it is a slider that is Depth. Increase the slider to about six.

Work you way down and you will find another button reading: RayTransp. You have that one depressed, below it is another slider increase the slider to ten.

This button (Depth) alows for up to ten transparent surfaces to "looked through before reverting to the objects preset color.

I would have to see your texture settings before I could tell you what was wrong with it, but most likely you pushed the button that (Blast! I can’t find it!) reverses the images colors. I know its in there somewhere.

Great job so far!

I hope this helps.

-aML

im having the same problem.

do you change the ray mirror and depth of the liquid or the glass?

If you’re rendering with yafray, you adjust the ray depth under the render settings… it’s on the tab labelled ‘Yafray’. A depth of 12 will cover just about anything you’ll want to have rendered.

enricoceric - I think that is probably what is wrong, as I was adjusting the paramters under the material, and not in the yafray settings. doh! But I’m still having difficulties, even after increasing the depth to max.

enriq766 - I may have to try a black bottle. :slight_smile: this liquid color is driving me up the wall.

zog34 - The options you are citing are only on the internal render engine, I cannot find them once I activate yafray.

Mr Man - YEa I changed the mirror value from default (if you select clear glass, or colored glass pulldown the mirror value is 1.0) I pull that down to 0.10 and the IOR change to 1.35 for the liquid.

xzzy - makes sense, but I’m still messing something up. Here’s one with the depth at max (I also turned off the cache and photons button… and the render time went up to about 13 hours… whew)

http://img413.imageshack.us/img413/7770/bottle100depth9ly.th.jpg

Apologies enricocentric… You hit the nail on the head with your response, but i was not seeing the right depth value. I was looking at the yafray GI depth slider, and not the yafray raytrace depth slider (different tab) and I actually didn’t ralize my mistake until I was reading a similar thread in the yafray forums. double doh!

Here’s the results after increasing the raydepth.

http://img327.imageshack.us/img327/7210/ybtest1nd.jpg

I still need to figure out what I’m doing wrong with the label, but its a lot better than my earlier render.

Thanks for the guidance, just wish I had actually seen the correct slider about 20 hours ( and several test renders) ago.