Why is the quilting on the sofa in the first picture more distinct?

The place settings are courtesy of Blenderkit and the creator is La Trosieme Dimension Christelle BOUQUET-AUGE and it is called Table Set Rayas.

Hanging light is from imessh, desk is from Blenderkit by Fossarius One, the 3 chairs on the right are from Kanzel Misel, the small table lamps are from Blenderkit, the office chair is from Blenderkits jhon cruz. The other furniture is from Chocofur. I modeled the tufted black Sofa.

The trees are courtesy of Andrew Price the Blender Guru.

1 Like

Lighting. In the skylit scene, see how strong that reflection stripe is on the legs of the right chair. Maybe there is a specular component to the sofa material that is a bit over the top. Don’t really know.

I had to enable the wall behind the camera because I was getting reflections in my windows of the outdoors. The reason the sofa is darker in the bottom picture is because I had turned off gloss in the World settings to get rid of the reflections. My viewport display color in the top picture for the V value was .250. For the bottom picture it was set at .906. I am re-rendering the scene in the bottom picture with the color V now set at .250.

Can someone tell me why there is no reflection in the windows of the outside, behind the camera in the top photo? Yet when I try to render with my gloss turned on in world settings in the top picture, I get reflections in the windows? I am thinking of getting rid of the windows in the bottom picture so i can retain the glossy look of the Sofa.

The outside lighting looks overexposed in the upper photo, that’s why it’s gone all white. If there were any reflections in those windows, they would be lost in the glare.

The world settings are at 50 w in both. I will recheck tomorrow. If I want to replace the glass with something else where the glass panes are what should I do?

You know, on the bright side*, the problem looks very much like what you encounter when trying to take real-world photographs of a daylit interior on a sunny day: getting a decent exposure of the room tends to mean overexposing the windows, and trying to crank things down to avoid the latter then means a gloomy interior shot. So you can blame Cycles’ physical accuracy for your problems. :wink:

*So to speak

1 Like

How do I get rid of these reflections?HOW%20DO%20I%20GET%20RID%20OF%20THE%20REFLECTION%20IN%20THE%20WINDOW Thanks, the reflections of the outside. No wall behind camera. The top photo has no reflections and no wall as well. I am stumped.

Take off the glossy portion of the glass shader? That takes it away for night shots as well, so no interior reflections either. For a day shot, the reflections tend to be blown away completely, so you could make the glass completely transparent instead (or make them render invisible if you can).

Personally, I would close up that other end.

Btw, those trees doesn’t look good to me. Either the house is slanted or the trees are located on a very steep hill outside.

Share the room and windows if you want us to experiment with solutions. None of the other stuff is needed.

1 Like

In Archicack you can disable the glass and enable portal. It was the"only" solution. In World , Glossy needs to be enabled so the sofa does not look like the bottom picture in the 1st post. I will try later to see if the portals alow me to re-enable my wall behind the camera, otherwise the sofa looks dark again. Than you to everyone who has given me advice on this post.

Am I missing something here? Why not just turn off glossy on the glass window panes object?

I tried maybe 10 times in 2.8 and it would not work for me. I was clicking on the window panels in a 2 panel window. Maybe I needed to click on the main window. I will try it later when my render has finished. Thanks for your advice FireMe.

If you mean object/visibility/glossy, that will make the whole object invisible to reflections rather than just the panes. I don’t know how archipack does windows, you might want to separate out any non glass stuff and leave them glossy visible.

Here is a new render.

This is taking so long the orange juice is going stale. Alot of the models are from Chocofur.

If you have no wall behind the camera, you are killing a lot of the realism of the lighting.

My advice would be:

  • keep all the walls
  • to have good illumination in an interior, you need a lot of bounced indirect light, in render panel -> light paths select the “full global illumination” preset, or at least crank all the bounces to something around 24.
  • the windows glass… if the glass is clean, and perpendicular to the camera, it should have no reflections, so, you can delete the glass or give it a transparent shader, the result will be the same and it will render faster. For glass not perpendicular to the camera the archipack material should be ok.
  • try to keep the world strength to 1, and play with the exposure in color management, if you render with a lot of bounces you should get good results and not need to augment the world strength.
  • avoid limiting the AO bounces in the simplify panel for the final render.

Huh? I start out with sky texture strength 40 and sun strength 400, then tweak the exposure - this gives me a fairly realistic starting point that is compatible with my indoor lighting assets (wrt strength). And no clamping whatsoever initially; observe first what it should look like before starting any clamping hacks so you know how and where to compensate.

Lots of bounces will help clean up, but only marginally at some point. How many bounces you need is strongly dependent on the geometry of the space you lit. 24 sounds like an awful lot for a square box.

If you do use a tiny hint of global AO over tons of bounces, keep in mind that Principled shader sheen parameter reacts very strange to that (last I checked).

Sorry, I was thinking in the use of an hdri when talking about the world strength.

HDRIs are not absolute, so all bets are off. Are you using a sunlit hdri, overcast, night city scene, or milky way?

In this case, I’d start with sun&sky (or just sky) to set my initial exposure. Replace it with HDRI. Then adjust the HDRI strength until it approximately matches what you’d expect for the HDRI scene at that exposure. And then there is the problem of the sun very often being clipped in brightness.

This isn’t science, so impossible to get it “correct”. There is eyeballing it involved since HDRIs doesn’t contain absolute values. The final render may be off a little in exposure, but light sources should end up in their respective area automatically.

There is nothing “wrong” by using neutral exposure, except your indoor lighting may need to be tweaked every time they are used, in order to stay in adequate relation to the HDRI used.

Personally, I don’t see the advantage to using HDRI for indoors anyway over sun&sky (I prefer just sky if I can choose to avoid the sun). High contrast HDRI takes long time to automap and long time to render. Sky texture resolves much faster, and although not very intuitive, you can still manipulate colors around if you want (or mix stuff).

I wish we had a physical sky, with camera visible sun disk, corona, position and time controls, north setting, and the whole lot.

Thank you everyone. That is a lot of information. I will try to make sense of it. You guys are really helpful. I will answer some of the questions later. It is a daytime scene. I am looking for a non-reflective glass. Can anyone tell me where I can get one?

oh I thought the glass panes were separate objects, if not just separate and all with be good.