Why is the subdivide so crappy!

Im using 2.23 and when I subdivide sometimes it gets all wrinkled on the sharp edges. Has any one seen this before or know how to fix it.

Hi, I know what you mean. You could try a couple of things.

Try Simple subdivide instead of Calmut.
Try to remove any triangles you have around the edges. Subsurf isn’t a great fan of tris.
Bevel your object before applying subsurf. Enter edit mode for your mesh, hit W key, select bevel and number of recusions move mouse for ammount.
Turn off Subsurf. Go to edit mode, select all verts, hit W key, select Subdivide smooth. Adjust ammount (100 very smooth 0 not) and confirm.

Hope this helps. If not you might have to remodel.

Sonix.