Why is the Sun going through my walls?

OK, i have a very simple problem, and i’m sure it obvious how to fix it.
Basically, when i tried using a sun lamp to light my window, it made everything inside gain light. Initially i made everything completely “dark” inside the room. No windows, no lights. Just a double levelled box around everything acting as my room. But when i rendered it still had light, the only thing that works is using a spot lamp but it gives an unnattural light effect, because it of course has sides that splay outwards, unlike the real sun.
Does anybody know how to fix this?

The first picture is the one with no windows or opening, the second is with my window made (but not finished obviously):confused:
Mind also that in the second render the Lamp gives no diffuse, only specular.


Do you have ray shadow selected on the sun lamp and can all the material types recieve shadows? possibly transparent shadows if you want it to go trough the window?

All of my materials have ray tracing enabled, everything appears to be correct…it doesn’t matter so much now though, i have already changed to using a a spot lamp placed a long distance away so that yuo can’t tell the distortion effect on the back wall. But i would also llike to point out that i have used these exact same settings for other things in 2.49b, i have absolutely no idea why this is happenning…

Try using area lamps instead of a sun light. You can fake the lighting a bit better better without the issues of it leaking through the walls.

This is a great tutorial on interior lighting setups. The tutorial is for 2.49, but the blend files available for download work great in the latest builds of 2.5.

Also check this out for some lighting ideas. I found a lot of useful samples inside the blend file here. http://blenderartists.org/forum/showthread.php?t=204210&pagenumber=

In the end i managed to fix it…although i don’t know HOW (lol)
I just put some more stuff in the scene, changed everything to Reflective instead of specular ect.
and then i added a few lights inside the room and for some reason it completely dissapated the effects of it…Absolutely confused but none the less it’s getting there!
/ Down there /
But as you can probably see i have one other problem…For some reason the effects of the sun arent appearing on my table. It is not showing the beam edge on the table. :confused:
(dont worry about that random plane, its just to demonstrate how the sun doesnt wana work…)


The light from sun lamps passes through all walls unless you have ‘Ray Shadow’ selected which allows the walls to cast shadows. Note also that the sun lamp only indicates the direction of the sun light, it is not the source of the light so can be placed anywhere in a scene without impact as long as you don’t change its direction.

This is a giant pain in realtime scenes…