Why is there lumpy jagged grey shadows on my mesh?

I’m just wondering if this is a case of not enough polys, but I’d prefer not to add too many polys to this object. what is the gray uneven jagged shadows?


Could be custom normals. Did you import it?

How did you handle the mesh on the flat area?
When using the Subdivision modifier, it looks similar to when the topology configuration is incorrect.

no I made it myself

The flat area is a separate object, pls ignore that haha

oh by incorrect topology where do you think I went wrong? Because it’s all quads, pretty evenly spaced. So I don’t know where I made the mistake

Ok. Its hard to tell from the screen alone. Best is upload a blendfile with that mesh or a part of it.

strangeshape.blend (1.2 MB)
Thankyou, here’s the strange shape blender file.

No, I cant replicate your problem. This is just solid viewport shading right? Does it still occur if you change the lighting to another lightsetup/matcap? And you have custom split normals. So try to delete them and see if that helps.

2 Likes

oh that’s super strange, yeah it just happens in viewport shading(solid preview) for this particular object. Cleared split normals and it still looks the same :confused: I’ll have a go with matcaps. thank you

Edit… :sweat_smile:

A similar problem sometimes occurs when importing externally modeled objects.

dgs

This is solved by initializing the rotation and scale. (The reason seems to be too small a number.)

Sometimes the jaggedness comes from not setting View / Clip start / End correctly.

The oval one has inverted normals…

After I applied scale and rotation ( like @oo_1942 said), and added a subdivision modifier set to one, and a smooth by normals…
This is what I get…

of course, I checked and merged by distance… I deleted one of the edges around the inner curve of the oval, as well as relaxed the vertices to smooth things out…as my standard workflow for fixing meshes…

1 Like