why is this option greyed out?

want to set a UV Layer Source, so I can paint to the diffuse Map.
It’s Blender v 2.59, so it must be feature complete:


An example of how i would do :

In Edit Mode i need to create an UV and load an image for it (or create a new image for it)
(here’s a simple project view unwrap from the front of the model and rescale it to follow the shape of the picture)

Then always in Edit Mode , you create for the same object another UV by clicking on the little “+” there :

You unwrap differently/load another image
(here’s i unwrap with a project from view but from the side of the model and get the UV following the image shape)

And finally i create what will be my final UV, and load /create a new blank (there it’s just black) image for it, the 2 other UV will then be used for the projection painting as the layer source for my clone painting.

Next, in Texture Paint mode, i select the Clone brush, and doing so i can know enable the Layer option, it’s not greyed anymore and i select from which layer i’m going to clone paint.

Once done

Thank you so much! I had already followed the other steps (but my screenshot might not look like it because I was fiddling around), but I hadn’t got the clone brush, thank you again!