Why isn't this smooth?

I have the object in the picture set to autosmooth at 30 degrees. Most of it looks fine, but you will notice there is one face on the right hand side that doesn’t. I checked the normals, and they are all pointing outward. Any ideas what is causing this or how to fix it?


here is the .blend.

try this: edit mode >>> select all >>> recalculate normals (ctr+n)

I don’t ever use the autosmooth function because it only works at render time. I like to know what faces are smooth in my 3D window.

The only thing I can suggest is you have to remember:

Only faces that have been set as smooth will be affected by the AutoSmooth feature.

Try selecting your model, press set smooth and then render.

Thanks, but neither suggestion seems to do the trick.

in edit mode, turn on draw faces [in the edit buttons] then go to wireframe mode

try to see if there is an extra face there [would be darker blue than the nearby faces]

or, you could try pressing shift+alt+m to select the non-manifold regions, and see if that selects an edge across there


I didn’t see the .blend before

so, what I suggested doesn’t apply here, paprmh seems correct

[personally, I don’t like ray shadows and avoid them unless absolutely necescary]

I am not sure why, but you have one spot (lamp) set to buff shadow and one (lamp.001) set to ray shadow… It seems to have something to do with the ray shadow of lamp.001- if you either set it to buff shadow or rotate the lamp (rotate around cursor from top view)just one degree that shadow dissapears-you seem to be catching that one edge in the mesh at just the right angle to cause a small ray shadow. catmull-clark subdiv set to 1 fixes it also… but it changes the basic shape of your mesh somewhat…

I am not sure why i had one set to ray shadow either, but I don’t anymore. I appreciate the efforts of everyone who gave this a look.