Why painting just does not work

Blender 3.1 on Windows 10
Long time i did not use texture painting in Blender, back for some low poly work model for a mobile game.

Can’t paint on saved texture, while everything looks ok :

  • Texture saved
  • Texture assigned to shader node
  • Paint mode on

This is the main issue with Blender, sometimes simple things that should work as expected do not work because there is hidden option or some requirement to do before.

Even for very simple things like just painting on a texture :joy:

Look like it works in 3.3.0 Alpha.

Have you tried setting to material preview?

Are you using Cycles? as there is a known issue with texture paint and cycles…

I tried in solid mode, even just the “image” mode view and paiting, nothing works.
Also tried without shader node and simple material, choose the texture for the color base, not working.
Downloaded and tried Blender 3.1.2, same issue.

Perhaps this is some setting somewhere.

This is the file if you want to try it

Try adding a UV node to the texture node.

The model has already UV as in picture i posted.
Adding UV node to the shader does not change anything, i also tried simple material without shader and this is the same issue.

I think it’s more of some hidden parameter or tweak somewhere.

Try this:
Open a new Blender file, add a plane, go to shading workspace, click new to add material, then Shift A to add Image Texture node, then click New on the node and create the usual Untitled image. Then go to Texture paint workspace and draw on plane with mouse. Should paint white. I just did this and it worked fine.

1 Like

Just cut n paste to a new blender file, re unwrap (smart project) I think there is something wrong in yr file but could not locate it…

Every import on Substance Painter or Mari to paint, never bugs like that.

There is UV mapped object, a texture map, a material, nothing complex, so Blender should be able to reset the cache or other stuff when opening the file and be able to paint.

This kind of bugs that should not exist :rofl:

Thanks, i’ll try to make a new Blender file then.

Hey there!
Look in the Active Tool (Brush settings), you have a black Texture assigned. It makes your brush useless.

5 Likes

You somehow managed to get a blank/black texture for your brush. Delete it, and the problem goes away (in your Texture Paint space, N-panel, Tool, scroll down to Texture, expand it, and x the thing).

3 Likes
3 Likes

Hmm you seems to be have choosen to use a texture… for the brush… the same black texture you want to draw to ? or clicked accidently new?? … So if i select the Untitled.png in the Shader editor and in the Image Editor for Paint and then select Texure → Unlink data block then i can texture draw with you file with no oher changes.

12 posts were split to a new topic: Blender texture painting vs substance painter