Why spot light coming throught the mesh

Why spot light coming through out the mesh. Im rendering in 2.82 Eevee. The scene has volumetric. Any suggestion. Thanks

So, I had a similar issue. Although I can’t say why the problem is happening, I can say that it stopped happening when I turned volumetrics off. I know it isn’t a great fix, but it is what fixed it for me. Best of luck!

I’ve had a similar issue with volumetrics in EEVEE. I solved my issue by moving the light further back away from the object it was passing through. But that does not seem to be an option in your case.

I hope this will help, I think that’s called “light leaking”. I wasn’t able to find anything to solve a simple mockup of your problem but maybe you can. Two sources I found that seem relevant;https://developer.blender.org/T71208 , https://blender.stackexchange.com/questions/131061/eevee-2-8-the-light-goes-through-the-egdes-of-a-simple-cube/131077#131077

@atekdigital, I took a look at the project I was having this issue with, and I may have come up with something that might help you - depending on the needs of your scene. By default, I think the Volumetrics Start value is .1m and its End value is set at 100m. My guess is that the samples used for volumetrics are also distributed throughout that Start and End value range to give you your final image.
Now, for my project, I didn’t need my volumetrics to be distributed from .1m to 100m. I only needed them for about 10m. What I expect happens is those samples are used in a much smaller space giving the appearance of higher volumetric “resolution”. This higher “resolution” was exactly what I needed to keep my light from showing through my mesh. I hope this helps and you can easily get your scene working the way you want!

Here is the setting I was talking about:


Thanks for the solution it work for me @ 25m. Here is the result.

1 Like

That’s awesome! Looking great, @atekdigital! I’m glad I could help!

1 Like