Why the RGBA channells of OpenEXR Multilayer output is empty?

Blender’s exr outputs seems as black when open with AE, Nuke or any EXR viewer like djview.
This makes difficult to browse files. Every time you need open in AE and aply extractor for viewing image. But open the EXR outputs of the other softwares like maya, you can view the image. Is it possible in the Blender?

Hi,

In Blender if you switch the Editor View to File Browser you can display all .exr in a folder, and setting the display mode to “thumbnails” works perfectly for me

See you :slight_smile: ++
Tricotou

No. Blender File browser not shown this Multilayer EXR .
Where do I do wrong?
Here it is My output node setup. By the way, I prefer to compositing in AE

Most Adobe applications don’t play well with .exr’s or multi-layer exr’s for that matter. Or linear workflow, or exr alpha’s…

Most compositor applications will be able to load the multi-layer exr just fine, but than you will have to split out the internal layers. Nuke, or Fusion work that way. Load one file, split it up and work on the various parts of the file.

afaik there is no viewer out there that can show you all embedded passes. You will have to load a file into a compositor to be able to see the embedded passes.

And if you want to render just one exr with all the passes embedded, just render a multi-layer exr.
No need for extensive output setups. Unless you want all passes to be a separate file.

Rob

You shouldn’t be using comp nodes like this.
With that setup.

  • You’re slowing down rendering through unnecessary compute.
  • Throwing away cryptomatte’s metadata.
  • Breaking your motion vectors.
  • Confusing exr loaders by not having your beauty assigned to RGBA (the reason it isn’t showing correctly in djview)
  • Likely inadvertently baking in a color transform.

Just disable comp nodes and render a multilayer exr as it is.

I connect combined output like this, my problem solved.

@Ben_Morrison I dont want to multilayer exr as it is. Because RSMB nodes. Regular vector output did not work for me or I could not. I need the Cryptomatte data in after effects. Why am I throw it? I cant understand.

Why adding all into one Output node? Not two, one for each Render Layer that needs more Passes split? Now it’s a bit of a jumbled comp, and like Ben told you, it will break some of the data in there.

So for the Shadow Render, you just add the vector pass for the View Layer, add a MotionVector input to the Output node and render it like that.
For the Objeler Render, add all the Passes you need, and add the same inputs on the Output node.
Render that one too. Now import all you separate renders into AE and comp away.

Not sure what RSMB expect as a vector, but why is the Blender vector not working for you?
Not really get it why you are ‘compositing’ a vector output for output in RSMB.

SBL_JENERIK_ATATURK_V01_1150.exr (2.0 MB)

Here is my render. It is work for me now.

I got this render as Ben said. So I just disable the comp nodes and render a multilayer exr as it is.SBL_JENERIK_ATATURK_V02_1150.exr (3.0 MB) Motion vector pass of this render it is not work properly with RSMB. So I did node setup like @Silverland How to render vector pass?

In the next post, the node group author explains that he’s blindly making shit up and it didn’t actually work properly. If you think it’s working properly, then it’s probably wrong in ways you can’t see and will be more noticeably wrong in other situations.
You need to remap the raw vectors into an appropriate format within After Effects. Doing so will allow you to quickly test different mappings to find the appropriate changes. Once you’ve found the right transformation, you can save it as a preset.

Yes, I adjusted some properties of RSMB in AE, motion blur works fine for me now. But we are return to start point. Rendered EXR files seems black. Sometimes I need to browse them, without open in AE.

Hi, no other adjustments should be needed to get it to work in after effects. From what I heard you just use the red and green channels from blender’s vector pass in outside compositors for motion blur.

I don’t use after effects and I wanted to verify if this is correct, so after some searching I found this statement:

and this info from https://help.revisionfx.com/task/21/#/tutorial-86 :

So if this is all true, then the other apps just output the data for the current frame to previous frame transformation, and reelsmart motion only expects to get the red and green channels where this data is stored.

This helps confirm what I’ve read elsewhere, but like I’ve said, I’ve never used after effects or this plugin, so I can’t test this to make sure that’s all you need to do.

Edit: Ah, sorry. I didn’t see that you figured it out on your own. You might have posted that while I was still typing this earlier.

@Zanzio I it is very very helpfull. Thanks so much. I solved my RSMB problem with your answer.

Annotation%202019-10-21%20111059

And RSMB Max Displace setting is 1 good for me.

Actually the beauty is not showing up in rgba by default…is it??

I was inaccurate on that point. ‘Beauty’ passes are written to the EXR as {render_layer}.Combined.{channel}.

So the only way to solve that right now is to go through a compositing fileout?
Besides other mentioned downsides it would also mean that your depth channel will be reduced to half-float if you want all other layers to be half-float…opposed to the default multilayer-output that would take care of keeping depth in full-float. correct?

No, there’s nothing to solve, and you should not use compositing nodes unless you’re doing compositing. Using the file output node like this is incredibly misguided. All layers are stored correctly in the multilayer exr by default.

Specifying per layer float accuracy is probably not going to save a significant amount of storage and I’m not sure that the file output node applies per layer accuracy anyway.

But not having the beauty in RGBA is actually quite annoying, e.g. RoyalRender creating fastloading preview jpgs for your render which are all black now, or djv showing a black frame on startup…

That’s not a valid reason to engage in an incorrect hacky workflow.
DJV in most cases does default to ‘combined’, and Blender can also output preview jpgs. That said, DJV is not a particularly good tool for not offering layer defaults strings.

Understood…

How do you set this up?

I am currently exploring how to integrate Blender into our pipeline. Just to clarify why I am asking so many questions…

1 Like