Why this is happening

Every time I do sculpt and baking the Normal map
I get this > Small cubes in the map


It looks like you forgot to set something to smooth shading.

My friend I tried but did not work

Please ALWAYS supply an example .blend file with any support question.
If you can’t figure this out with the file in front of your eyes, how are we supposed to do that without?

I can not give you the file. not now.
But there is one solution to resolve this problem . I need to delete the Multires and add Subsurf then Apply it
after that add Multires and Sculpt it over again . When I bake it will look good
But I do not want to do that
I need anther solution .

You could try switching to cycles for baking https://www.reddit.com/r/blender/comments/40taa1/normal_map_baking_looks_blocky/

:slight_smile: thanks all of you

but the normal map in the render looks not good > look to the seems of the edge in the model

how to fix it


probably due to the uv islands are to small, when you bake you bake the image bigger (default 16 px i thought) then the uv island.
so do some placement adjustments and bake again, should solve the problem. or lower the bake offset. (can’t remember how its called, just an option at the bake settings) and also be sure to leave a few px between the border of the UV and the uv islands.

Why is there an alpha channel in your normalmap ?
It seems to be messing up your padding. (margin)

Try to follow this for the normalmap setup: https://www.youtube.com/watch?v=kOgRDzarx98

Why is there an alpha channel in your normalmap ?

depending for what you use it, in some game engines(like upbge) you need alpha channel to create parallax map.