Why will my fluid domain only bake once?

I’m trying recreate Ian McGlasham’s “ALICE” fluid animation. In the process, I’ve been trying to adjust settings for the size of my fluid objects and also for the resolution of the domain object, so I want to bake the domain, see the result, adjust things accordingly, then bake again. However, after I bake the domain once, when I try to bake again, the baking progress bar appears and progresses, but the fluid and domain object do not merge to become the flowing liquid. I assume there is a “Free Bake” somewhere that I’m supposed to click on but I can’t find it. In addition, if I just go and manually find & delete the fluid cache folder in my computer, the domain still won’t bake properly. Also, I’m using 2.70 (Hash: 19e627c).

To show what should happen when you click Bake, I made a simple demo blend with a small inner cube as the fluid and a big outer cube as the domain:

https://youtu.be/R17kkANH9KA

See how the domain and the fluid objects merge into the fluid mesh? That’s what should happen, but that doesn’t happen for me if I click Bake a second time.

Here’s the layout of my scene:


Here’s what happens when I try to bake a second time:

https://youtu.be/iTph7EEgLGc

See how the domain and the liquid objects stay separate and do not begin to flow? They should, but they don’t and I can’t figure out how to get them to.

One person suggested after baking I try playing through the animation, so I tried that but the domain and liquid objects stayed separate and did not flow.

In my tests, it seems that if a domain contains 2 fluid objects, the second baking will not work. Does anybody know if this is accurate? If so, is this a known limitation of Blender or is it a bug?

Here is my blend file.

Also, as a side note, is it weird that one cube inside another cube requires 27MB of memory to bake, but the other more complex scene only requires 1.89MB?

I took a look at your file and there were some changes I made. I turned off physics collision for the collision object. The fluid sim collision is all that you need. You had two Fluid squares without any velocity. I turned those into Inflow objects with a negative Z velocity to force fluid down into the collision object which I set to Shell instead of Volume.

When working with fluid collision objects thin walls are not good because fluid velocities can exceed the gap and drop through the barrier. So I extended the outer walls of the collision object quite a bit. The workflow is to calculate the sim with a chunky collision object then swap in a finer detail one for rendering later.

But the main problem I had was with the path to the fluid cache. When browsing to a folder to place the fluid cache into make sure to un-check Relative pathing. At least on Windows it seems to help Blender find the folder better.

Give the attached file a try but remember to browse to a new fluid cache path (un-check Relative) before attempting to Bake.

Attachments

27_THOM fluid text.blend (133 KB)

Thank you Atom for your help. One note: I don’t want to use inflow, I only want a small amount of water so I can recreate Ian McGlasham’s “ALICE” fluid animation.

I have definitely made some progress, because now I have gotten the fluid to bake whenever I want it to, but now I am left with one more problem: when the fluid fills the text container, it doesn’t fill it all the way – it leaves a small gap between the container’s edge and the fluid:


Previously, this gap was much larger and I made the gap much smaller by increasing the Final Resolution of the domain object from 65 to 200. This was a HUGE improvement, so I assume maybe I need to increase the Final Resolution even more to have the fluid finally touch the walls of the container. However, when I see how finely the fluid mesh is already divided, it’s surprising that’s not enough resolution/faces to be able to conform fully to the container walls.

Since the fluid mesh looks like it should have enough resolution (small enough faces) to conform to the shape of the container, I am wondering if maybe I need to change the Surface Smooth and/or Surface Subdivisions settings in the Fluid Boundary section, or do they need to be used at all? As you can see in the picture, I have Surface Smooth set to 1.0 and Subdivisions set to 3. I read that increasing these can greatly increase the render time and may also cause Blender to crash if you run out of RAM, and I only have 2GB of RAM.

So, in order to get the fluid to fully conform to the container, do you think I should:

  • increase the Final Resolution
  • increase the Surface Smooth
  • increase the Subdivisions
  • or some of each, and if so which ones

Also, do I need to have the Surface Subdivisions set to 3 or can I turn that back down to 2 or lower? It takes so long to bake on my computer that I’d love to understand these settings and not have to learn by days and days of trial and error, so any help would be greatly appreciated!

Thanks!

Also, here is my current blend file.

Generally to get a good looking fluid sim I increase Final Resolution so it uses at least 1Gb of memory. The value of the resolution is not as important as the amount of RAM. I would hold off on smoothing and subdivision and try increasing the Resolution first.

Have you seen Edi’s tutorial on the fluid simulator? It really is worth checking out.

Thanks Atom, I’ll try that!

great recommend on the Edi tutorial. thanks.