Why won't this font work?

Ok, this is probably a really stupid question, but for some reason I can’t get this font to work. I created it manually with “ftblender.exe” since the .blend and python script didn’t work with Blender 2.41. But that shouldn’t matter, the file -looks- ok, it’s missing some characters, but why doesn’t it display properly?

Here’s the font .tga file:


One more question: How do I get -black- characters to work in Blender GE? Just “invert” the image?

P.S. - this might be a useful font for my fellow GE developers!


nope, even easier, use alpha instead of add mode, and vertex paint the face black.

I can’t get that font texture to work either

Thanks for the tip, z3r0 d. Sounds easy enough :wink:

Yeah, there must be something wrong with the .tga format. Alpha channel isn’t working and it doesn’t display characters correctly. I compared this .tga to the “arialbd.tga” that is commonly used in other games and they -appear- to be the same format (at least GIMP and Photoshop say they are), grayscale with no alpha channel. Wierd.

BTW, I wasn’t able to get “ftblender.blend” or it’s python script to work in either 2.41 or 2.37a. That’s why I manually set the file conversion options. I must have made a mistake somehow.

The command I used was:

ftblender -o LCD-BOLD.tga -x 512 -y 512 -r 53 ppem LCD-BOLD.TTF

which is what the script outputs… or so I think… I’ll check it again…

Ok, I found a different font that worked. So it definitely was a problem with the .ttf file.

Question: Is there a tutorial on how to apply vertex color anywhere? I want my text to be black, and can’t find a tut for a complete noob…

Maybe it has something to do with those dots at the top of the image of the font table?

Sorry, I haven’t messed around with text in the game engine yet…so I’m not sure if those things would make a difference in it working or not…just thought I’d point out that they’re there.

Yeah, that’s exactly the problem. I’m guessing that the font that I tried to use is not complete enough, so “ftblender” doesn’t completely convert it and it doesn’t work. It took alot of searching of past threads but I finally found a couple comments about how those dots are the “header” and are read by Blender.

Now I have to learn how to “vertex paint” so I can turn my white text into black. Any help?

Select the plane that the font image is on. Switch to UV Face Select mode. Select the face of the plane, set it to Alpha and change the VertCol by clicking on the box next to the button “Set VertCol” and select the colour black.

Ok, I tried that, and in “UV Face Select” the text is black. But when I play the game, the text is still white? What am I doing wrong?


I figured it out (well, at least I got it to work). I must have had a couple different text objects with different vertex colors but the same material, so it used the old vertex color. Now that all the objects with the same material have the same vertex color, it works. Magic :wink: