Widescreen problems

Well, you guys talked me into buying the thing, hopefully now you can help me get it to work right. The problem, if you’ve not seen the old thread, is that when a 4:3 game goes widescreen, it’s distorted, and I can’t find a way to fix the problem. The nvidia control panel has its widescreen scaling options, but for some reason they don’t work. If I select “nvidia scaling with fixed aspect ratio”, it goes to all the edges anyway. If I select “do not scale,” I get a small, centered version of the same distorted image. I’ve been going through nvidia support trying to get the problem fixed, and they’ve had me try all different drivers, but none have solved the problem. Yesterday they told me that the card was probably defective and I should contact the manufacturer. I find this rather hard to believe since the card works perfectly in all other respects. (It’s a geForce 7600 GS).

Also, there are some strange things about the monitor in general. It’s an Acer X203W, and the included disc provides no drivers for it. I can’t find any drivers on the internet, either, except for one for Vista (I’m on XP SP2). The only driver Windows will use is the generic Plug and Play Monitor driver. (Although the nvidia control panel can identify the monitor.)

Furthermore, it seems to me that the monitor should have some way of doing this automatically, right? And yet it doesn’t seem to. Why not I can’t imagine. I’ve read the manual repeatedly, but I can’t find any mention of such a feature, possibly because it’s exceptionally badly written. (I’m trying to find a link to it online without luck. I’ve seen it before but can’t find it now. If I find it I will post a link.) The acer website, like the manual, is a disaster area. It’s like trying to find your way through an unfamiliar building where half the doors are locked and the lights are off. I may try calling acer and see if that gets me anywhere, but my experience so far suggest that I’ll have little luck.

The floor is now open to suggestions. Does anyone know of any fixes or workarounds? Or, if all else fails, how I can force games to display in windowed modes, even if they don’t have the option?

Could I suggest that it may be the age of the game (what game is it?). Most of the games that I have displayed on my widescreen have given the option of screen size 1080 x etc etc. SIMS2 (not a big fan) for example defaults to 4:3 with black at the sides and I had to go into the SIMS2 options menu to tell it what size it needs to diplay at.

It is partly the age of the games. It’s all my old Myst games, many or most of which do not have widescreen options.

Is your monitor hooked up through dvi? If not give it a try.

The reason why I ask is that I had a wierd problem with my dell monitor too. I was using d-sub for years and I could never figure out why all my text was blurry. Also my monitor was assigned analog driver everytime I tryed to install it. After so many attempts to resolve this issue I gave up trying to fix it. I figured my monitor was faulty.

One day, while working on my brothers computer I hooked it up to dvi input on my monitor and my computer was hooked up to d-sub. My monitor has 4 inoputs and lets me split screen space. This is when I realized what the problem was.

dvi input is digital so it should assign the right driver. not analog.

Yeah, it’s attached through DVI.

Erm. A problem sometimes, is the widescreen?

My old BenQ 15" LCD monitor just died at 3 years and 2 months (3 year manufacturer’s warranty)… luckily I got the Staples extended warranty. Since it was so old, they just gave me a depreciated value credit without even looking at it… almost enough to get a new widescreen on clearance, an Acer 21.6", which was cheaper this week even than it had been the last several weeks before Christmas. :slight_smile:

Interesting about the image quality. Originally tried the screen with the built-in video card (Unichrome S3) and was nauseated that my lovely new LCD looked like I had lost my glasses and was trying to see it across the room. Blender had some display problems with it as well, but I had anticipated that and was already resigned to getting another video card. Got an Nvida of course, given ATI’s ongoing issues with Win & Linux & Blender. The card was on sale, but only had VGA, no DVI port, but then I don’t think the monitor did either.
When I put that card in… I was blown away. It was exactly like the hype on the box, probably 3 times sharper! Not to mention the literally 5X-10X faster OpenGL framerate. I was afraid I was going to have to take the monitor and the card back, but I was VERY happy with the two pieces then. (The computer is a different story, took forever for it to stay working)

The new Acer is not quite as sharp, but better than the onboard video still. I’m starting to wonder if I’ll need another video card with DVI to get my sharpness back, or if the monitor itself is to blame. I didn’t see any drivers either, plug&play is working okay I think. I’ll have to try some of the old games too I guess.

Oddly, the monitor is just getting the VGA input, but configuration is automatically is setting itself as digital input instead of analog. Can you have digital VGA input?

Widescreen is the standard these days. So you did make a good choice.

  • Right-click on the desktop and select Properties.
  • In the new window, find the Settings tab and click on the Advanced Button.
  • In the new window, there should be a tab controlling the display minutiae; usually it is appropriately named “Displays”. Click on that tab.
  • What follows from there depends on the manufacturer of your graphics card and the driver version that you have installed. There should be an option described along the lines of “scale image to panel size”, which you should uncheck. This will cause the game to run in its intended aspect ratio.

zanos: I have found these kinds of settings in the nvidia control panel, but unfortunately they do not work. I have attached two images showing the results I get with a little test pattern I made with the BGE. The shapes on the display should be a perfect circle and a perfect square if displayed at the correct aspect ratio. As you can see, when the card is set to enlarge the image but keep the correct aspect ratio, it fills the screen to the edges anyway. If it is set to not scale the image at all, it does do letterboxing, but bizarrely, the image is still distorted.

Attachments



I am not sure about this but I think there are some AGP cards available.

Im sorry man, I got no more suggestions.