widget move on a plane ?

on windows 32 bits
how do you use widget and make object move on a plane

i tried the shift with cursor over one widget’s axis but it does not work!

so what’s the trick here?

thanks

Shift-Click-Drag works on my Linux 32-bit version… in Object and in Edit mode. (I just checked.) Blender 2.66+.

But that’s a feature I seldom use. I always type [G] and [SHIFT X, Y, or Z] which defines the axis on which I don’t want to move.

tried again and not working

do you do shift then release and cursor over blue Z axis and move object ?

or 1 keys down with cursor over z axis and move object ?

thanks

I press and hold [SHIFT], click the axis and drag. At the end, I release the mouse button first, then [SHIFT] last since it as no effect alone.

And if I want to cancel, I don’t even release [SHIFT] to do the [Right-click].

something happen i can see new axis added
like if i select Z axis then i see red blue axis lines added but the cube moves all over XZY
not limited to plane XY!

thanks

Check the coordinates on the N-panel. It’s just an impression. I feel the same when there’s only the usual grey background which offers no point of reference, especially in orthographic mode. Look at the coordinates and you’ll see that Blender works as expected.

ok your right very nice illusion!

thanks