Wierd artifacts!!!! Urgent help needed to solve

Hey guys, I’ve had this in a few of my scenes these days and i need to know whats wrong with them…
look here:
(btw, i stopped it rendering since it was taking too long (notice black edges), but it did finish the first few times and it did the same thing. it’s really messed up and it’s even worse when it’s animated)


This was in 2.53 but I get the same results in 2.49b. I can’t fix it. It’s pretty urgent since I have the same problem for a scene in my short film.
It’s not my computer, I sent it to a friend an it does the same thing.

If you want to see the wireframe and screenshot (solid) go here:
http://www1.picturepush.com/photo/a/3989374/img/Picture-Box/prob.jpg
Its full res btw.
You can see the scene size (relative to the grid) in the wireframe if you look carefully. It’s only slightly bigger than the grid

Hi gregzaal !

This two edges left and right of the paved way - you do have them subsurfaced, do you ? Or did you just set them to smooth ? If you just set them to smooth, try setting them back to solid and subsurfacing them.

If this is not the case or this does not help : Switch to edit mode with the mesh of the floor selected, select all vertices, remove doubles. Then hit Ctrl+N to recalculate normals. Render again and hope that the artifacts have gone :wink: If this is not the case, switch to edit mode again and go to Editing (F7). There should be a panel called “Mesh Tools More”. Activate Draw Normals and Draw VNormals there. Do you see some unnatural looking angles between normals and faces ? If this is the case, try recalculating normals again, look if the angles look normal. If this is not the case, try to remodel your mesh or choose a lower subsurfing setting.

Maybe you should have a look at your material settings, too. Do you have a texture mapped to nor and a nor-value of 1.00 or higher ? Try setting it lower. Try different Shader settings, setting down specularity for example.

The artifact near the sphere is really odd. Do you have any transparent materials linked to your sphere or something else ?

Uploading a .blend might help a lot, too.

yeah it is subsurfed and smoothed.
thanks, ill try those…here’s the blend: http://www.mediafire.com/download.php?bawfqqm8b2w10mp its a compressed 7z
this one is a school project btw, and i still have a nazi army to make (and animate) along with ragdoll physics and splitting a building in half.

I’m sorry, forget my first post, i totally misinterpreted your problem, better don’t ask how :wink:
I had a look at your .blend, and i switched off ztransp for your tar and sidewalk textures, this solved it for me as far as i can see. Why did you activate ztransp in the first place anyway ? Let me please know if this solved it for you.

i had ztransp activated?? oh that would explain a lot… did you use 2.5 or a lower version?

I do use 2.49

strange… it works for me too now, but i had to do it in 2.49 aswell. 2.53 must have a different way to disable ztransp. i changed ztransp to raytrace in the materials panel in 2.53 and it didnt help. but then in 2.49 i just disabled ztransp and it works… thanks… i guess ill have to redo the animation (not much of it) then in 2.49. and forget about indirect lighting…

thanks

oh wait, i have an idea! i just save it as it is in 2.49 and then open it in 2.53! i just did that and it got rid of the problem! (still)

thanks man. indirect lighting is quite important in this school project

Glad you solved your problem, and thank you for posting your solution, i was having a similar problem, it got rid of it for mine too :slight_smile:

As a side note, the circles make a OMG face. It made me laugh :smiley: