wierd ipo

(anon125) #1

I am looking directly at the end of a cylinder.
i click I-select locrot.
move 10 frames
rotate the cylinder and locrot.
several times.
but when i play it
see what happens!
any ideas? I tried actually moving the ipo verts and this seemed to help but didn’t
what am i doing wrong
ver 2.42

Attachments


0 Likes

(Vertex Pusher) #2

I’m not sure if this is a bug or something but for some reason you can’t locally rotate something along a single axis without it getting all wobbly when it is not aligned to the global axes …

The only solution I can think of is to parent the cylinder to an empty and then move/rotate the empty into place then key the rotation of the cylinder . Then you should only have a single axis that has a change in its IPO curve … the other two will remain flat .

EDIT : Not to leave you frustrated that you might have to start over with setting up your scene here is a simple way to parent your cylinder to an empty without starting from scratch :

  1. In the top view shift-c to center the cursor to the global center and create an empty
  2. with the empty still selected shift-select the cylinder you want to animate and Ctrl-C -> copy rotation and Ctrl-C again -> copy location
  3. hit A to deselect all
  4. select the cylinder then shift-select the empty and Ctrl-P

Now the cyinder is the child of the empty and it’s rotations will have cleared to zero and you can proceed to animate … though another buggy thing is that the cylinder still keeps its transformations relative to the global center … if you clear it with Alt-G it will go back to the global origin …

EDIT #2 : Also you might want to delete all the keys/curves for the cylinder and save and reload before you do the above … the IPO curves tend to “linger” in the RAM unless you save and reload …

0 Likes

(anon125) #3

thanks for your help
Just remebered there was an ipo associated with this object before and it was in a completely different orientaion - it must have remembered!
I have now deleted the old cylinder and replaced it.
same problem!
I MUST be doing something dumb!
i started a new file.
rotated the cube and it worked fine.
so i then added a cylinder.
same problem!

0 Likes

(Vertex Pusher) #4

OK … sorry I forgot something very important in my post … actually I didn’t even realize this myself until I tried to follow my own instructions in my edit and it didn’t work … I was having a sleepless night and it was five in the morning where I was …

So the actual steps to getting your cylinder parented to and empty and cleared of its rotations is :

  1. Go into top view (numbpad 7) and Shift-C, Space -> Add -> Empty (you want to add anything you are going to animate in the top view to avoid unnecessary rotations in your object but especially empties as you cannot clear/apply their rotations)

  2. With the empty still selected shift-select the cylinder you want to parent and Ctrl-C -> Copy Rotation, and again Ctrl-C -> Copy Location (you might want to be in wireframe mode to see better)

  3. Hit A to deselect all, then select the cylinder and Alt-R to clear its rotations (you could also Alt-G to clear its current location)

  4. Now with the cylinder still selected shift-select the empty and Ctrl-Shift-P to “Make parent without inverse” . Now finally your cylinder will be back to the rotation and location that you placed it except its rotations will have been cleared to zero (as well as its location if you cleared it before - if you want to clear it now just Alt-P then Ctrl-Shift-P again to get it back to position)

Now since the cylinder as the child of the empty has no rotation or location relative to the empty, if you want to animate the cylinder rotating around its local Z axis you can just hit R, Z, Z, and rotate or insert a value into the RotZ : field in the transform properties window (you have to set the 3D orientation to local first) without the weird wobble …

Ctrl-Shift-P … didn’t even know that existed as an option … I spent an hour trying to follow my own instructions and then realized I must have used a hotkey combo without realizing it because the gist of the past worked this morning… well at least hard fought knowledge tends to stick better to my dull wits … and this is a very useful function to know …

Well sorry again, hope this helps you out …:o

0 Likes