Will AMD ProRender revive Eevee


Hi, I just came to know about AMD Pro Render from another topic here. I have a not so new AMD machine with

CPU: AMD A6-6400K APU (2) @ 3.900GHz
GPU: AMD ATI Radeon HD 8470D

For me, Blender 2.83 works fine on Windows 10 but lacks Eevee in Ubuntu 20.04. I wonder whether there will be any difference if can use AMD Pro Render in my machine ? Will it help me use Eevee ? In Ubuntu 20.04, 2.91 also works fine in Cycles but not in Eevee.

If AMD Pro Render would help me in any way, I would be delighted to use it on my PC. Please guide.

My full specifications from Neofetch

OS: Ubuntu 20.04.2 LTS x86_64
Kernel: 5.8.0-48-generic
Packages: 2243 (dpkg), 16 (snap)
Shell: bash 5.0.17
Resolution: 1366x768
WM: Mutter
Terminal: gnome-terminal
CPU: AMD A6-6400K APU (2) @ 3.900GHz
GPU: AMD ATI Radeon HD 8470D
Memory: 2645MiB / 7148MiB


Maybe, but the real question is why Eevee isn’t working for you. If it runs in Windows, it should run just as well in Ubuntu.

Where did you download Blender from? Are you running Blender in software mode?


Regarding your other questions, it’s an alternative Renderer, its not updating Eevee in any way, so no its not helping you using Eevee, it can be used instead of Eevee and Cycles. If you just have problems with Eevee and thats your reason to change, I am with @Renzatic. Try rather solving that.

1 Like

It could be the drivers. Eevee is faulty in Ubuntu 20.04 for me.

from blender.org

I am not sure what this means. I double click the Blender executable file and it works. Thanks.

Understood. Thanks.

There are usually two run files that come along with Blender: the appropriately named “blender”, and “blender-softwaregl.” You want to run the former.

The reason I bring this up is because that’s about the only reason I can think of as to why Eevee isn’t working for you. It could possibly be a driver issue, but from what (little) I understand, Radeon Mesa drivers are embedded within the Linux kernal, and should work fine right out of the box.

1 Like

@meetdilip, In Ubuntu you open the Linux terminal and you show the result that you get with each of these lines:

lspci | grep -iE 'vga|3D'

and this (requires your Linux password)

sudo lshw -c video


Please see the outputs below. Thanks

$ lspci | grep -iE ‘vga|3D’
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Richland [Radeon HD 8470D]

$ sudo lshw -c video
[sudo] password for PC:
description: VGA compatible controller
product: Richland [Radeon HD 8470D]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 1
bus info: pci@0000:00:01.0
version: 00
width: 32 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
configuration: driver=radeon latency=0
resources: irq:28 memory:e0000000-efffffff ioport:f000(size=256) memory:feb00000-feb3ffff memory:c0000-dffff

I went ahead and tried to install ProRender. It get installed, but when trying to enable, it gives

file name : RadeonProRenderForBlender_3.1.0_Ubuntu20.Release_March_2021.zip

Even after trying

sudo apt-get install libgl1-mesa-glx

Since you’re on Ubuntu, have you tried installing Blender from a snap pack? That’d take some of the guesswork out of things, since snaps come loaded with all the appropriate dependencies.

1 Like

Yes, I did. It has 2.82 or something. But the issue was there in the snap package as well.

Apparently it is an old gpu on which AMD dropped support a long time ago:

This is something common that AMD does for ATI cards in Linux, they quickly discontinue the support of the proprietary driver with the excuse that in Linux there is an alternative OpenSource driver, which especially for old cards does not have a good performance. AMD doesn’t even maintain legacy driver support for it on Linux.

I’m pretty sure AMD Pro Render doesn’t support the OpenSource “radeon” driver you are using.
Regarding Eevee, what exactly is the problem that you have?
With OpenSource drivers, any problem you have with Eevee related to 3D drivers, you should report the problem to the Mesa project (OpenGL Linux implementation for OpenSource drivers)

1 Like

Going by the errors you posted above, it seems Blender is having trouble accessing LibGL.so, which would point towards a driver error, but you’ve already tried installing the Mesa drivers, so…

Is there anything else you use on your comp that leverages the GPU? Any games or anything? How do they run?

1 Like

At the moment, only Blender is running. I have Inkscape and GIMP installed, but not used in this login. I do not play games, might have installed a couple of small ones from Ubuntu Store, but haven’t even seen them in last 2 months.

Did I do it correctly ? I followed an Ask Ubuntu question. Thanks.

It would nice to know how to fix it.

Yafu’s post above looks to nail the root of your problem. You might have to run back to Windows to keep using Blender. : \

1 Like

Cycles is working fine in Ubuntu. I am being hopeful :slight_smile:

I am not sure what the output of those commands mean

Look above. It seems you missed his post.

In digest, he said that it looks like you have an old GPU that AMD has dropped maintenance for, and the Mesa drivers don’t do a good job of supporting.

If that’s the case, there really aren’t many options for you beyond jumping back to Windows, or getting a new laptop.

edit: Or you could try one of those distros designed to run on old hardware. It’s a long shot, but…


1 Like

Missed this reply somehow, sorry. Eevee reacts strangely to light

In short, since AMD does not support the proprietary driver for your GPU on Linux then you will not be able to use AMD Pro Render on Linux.

But now let’s analyze what you meant by this:

What exactly is the problem you have with Eevee?

Can you open Eevee samples scenes?

1 Like

Okay. If you have a .blend file where you can reproduce the problem, you can report it to blender. Open Blender, “Help” menu and “Report a Bug”. This will redirect you to the bug tracker (you must have an account there). You fill out the report and you show the problem by sharing screenshots and the .blend file.

The developers will tell you if your GPU is currently supported by Blender on Linux.

1 Like

They said it is not supported. But thankfully, with the same hardware and Windows 10, Eevee is working fine. That is why I was curious when I heard about ProRender.