Will Blender 2.90.1 install on a Rasberry Pi 400?

Hello,

I’d like to know if it is possible to run the latest version of Blender on a Rasberry Pi 400? (Latest Keyboard version)

The older version of blender 2.79 works but I was really hoping to use the latest version of blender with its latest UI.

Would be great to do some low-poly modelling and basic rendering on this cheap computer. After all, you don’t want me to use maya for ever do you? .))

Cheers!