Winding order

Hi there,

I’m using Ben Omari’s DirectX .X exporter to get my meshes into my game engine, and I’m having some issues with Backface culling, that all of the faces in my mesh appear to be wound the wrong way (clockwise as opposed to CCW, I think).

It may be that I don’t understand Blender well enough, and that this is actually an issue with the exporter rather than with my mesh, but assuming that’s not the case… how does one change the winding order on a face in Blender?

the winding order and normals are one and the same in blender

hit control+N in edit mode to recaculate the normals outside [control+shift+N for inside]

turn off double sided in the edit buttons for the back of the mesh to be black

I think your problem may be that your object has a negative scaling along one or more axis…