Windows 10 May Update (v2004) and "Hardware accelerated GPU scheduling" break Cycles GPU rendering

Anyone have experience of the same problem?
I tested the problem in many Blender release and no one can render anymore in Cycles GPU mode.
I had to disable this feature to be able to use Cycles GPU rendering.
If you have Windows 10 v2004 release please update your NVIDIA drivers with latest release enabled to support this feature and double check.
It’s important to right report the failure to the Blender Foundation.