Windows 7 and Game engine (2.56a)

Hey, i’m having a problem with the game engine, just installed blender 2.56a and when i press p, blender crashes…
could someone help me?

note: blender 2.49 works fine(game engine)

Windows 7 ultimate 32bit
graphics: Nvidia 9600gt(latest drivers)
installed latest python

screenshot of console when i open blender:

edit: Problem signature:
Problem Event Name: APPCRASH
Application Name: blender.exe
Application Version:
Application Timestamp: 4d23935f
Fault Module Name: blender.exe
Fault Module Version:
Fault Module Timestamp: 4d23935f
Exception Code: c0000005
Exception Offset: 00485037
OS Version: 6.1.7600.
Locale ID: 2070
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

The Blender 2.5x series uses Python 3.1. Any script that is outdated will not work in Blender 2.5x. If you scripted anything using the “old” scripting language, it may not work. Also, many features in Blender 2.49 have yet to be implemented…

But, if you are just pressing “P” and there isn’t any game. That is an entirely different problem. Also, the game engine uses Python 2.something… Uninstall, and reinstall Python 2…, not 3.1.


thanks for the reply

installed python 2.0 and 2.2 and no luck…

nobody can help me?

i’ve searched for a while and there is some people with the same problem, but no conclusive solution…

didn’t anyone resolve this problem?

I don’t know if this will help you, but it helps me.
I had this problem for a while and eventually figured out what it was.

Turns out, Blender 2.56a does NOT like it when your save file is in a folder with symbols on Windows 7. (That includes temporary and .blender).

I saved the file I was working on in something like:

And it worked fine. As long as the folders don’t have “.” or something.

Does moving the save file to a folder with no special symbols help?

If it helps anyone fix the bug, I think I narrowed down the problem:
When I open this file:
Blender says:

And it works fine.

When I open this file:
Blender says:

And then crashes when I press play.

thanks for the reply, but even with just a cube in the scene, nothing more, it still crashes… if i delete everything in the scene-> still a crash…

Update your graphic card drivers, install Python 2.62 and 3.1, restart you computer.

latest graphic driver, installed python 2.62 then 3.1, restarted -> crash…

Are you using Blender 2.56 from the zip file or the installation?

from installation crashes at startup, i’m using the zip file

have you installed the VB Runtime?

installed now, still a crash in game engine(zip file)

have you tried the “Run as Administrator” option.

What I did is I installed blender in “my documents”. It did not work very well when it was in “program files” or in “program files (86)”.
I’m using windows 7 myself, so it should work.

Edit: Also, just to make sure you don’t have many problems, run it in compatibility with windows vista. I don’t recall doing that, but I think I did it (given that I faced problems at the start).

Hope this helps!

yup, still a crash. (#14 solution)

is there an email or something so that i can contact blender programmers?

blender installation crashes on startup, even if i the installed directory is in “my documents”…

edit: it doesnt crash at startup if i set blender data files to be installed in the installation directory…

but still it crashes when i start blender game engine

and tried with compatibility with xp and vista, running in administrator mode -> crash in game engine

  1. Completely uninstall blender and delete any leftover files in the programs folder.
  2. Download and use CCleaner, let it scan the registry and fix whatever issues it might find.
  3. Reinstall blender.

If all else fails, do a fresh install of Windows 7.

well, installed a fresh copy of windows 7, it works now…

thanks for all the help