[Windows] Set Blender version installed from ZIP as default to open .blend files

How do I set my Blender version that I installed from a ZIP file as the default to open .blend file types? I tried to set this by right-clicking a .blend and use “open with”, locate blender.exe and checked “always use this to open .blend files”, but whenever I click on a .blend file, it opens with an older version of Blender.

In “Open With” menu, “Choose Another App”, Click “More Apps”, click “Look for another App on this PC” and select your Blender version EXE.

That’s what I also tried, didn’t work for some reason.

Maybe it’s because 3.1.2 is already used here:

And i can’t seem to change that.

Preferences > System > Make Default Blender

I thought that should do it, but I am still at 3.1.2. :sob:
It’s not changing the file association.

Weird, works great for me

I don’t know, something must have corrupted this for me in 3.1.2. I would also think this should be the way to set the default version.

on Win i think EXE have to be registered as installed
then it will run it by default

problem is that you cannot save 2 programs / files with same name !

it would be nice if blender EXE and files had different Installed name

happy bl