Wings and Linux


(overextrude) #1

Is it possible?

I’ve spent a good anount of time trying to get esdl (a required component) to compile, and I run into a bunch of errors. I’ve installed the libGLU from most recent version of Mesa, and SDL. And, of course, without this junk, erlang won’t boot wings. :-?

If anyone has a tip or two that could save me some time, I’d appreciate it.


(Hos) #2

I have compiled it (but I also ran into probs compiling
esdl that made me postpone using wings for several
months). I can’t remember what I did differently this
time, but maybe if you post the compiler error that
will jog my memory.

Chris


(overextrude) #3

Thanks.

It runs into problems when it gets to esdl_glu.c:

ake[1]: Entering directory /usr/local/tar/esdl-0.91.0415/c_src' gcc -c -g -O2 -funroll-loops -Wall -ffast-math -fpic -DSHM -DPTHREADS -I/usr/include/ -I/usr/local/include -I/usr/local/include/SDL -D_REENTRANT esdl_glu.c esdl_glu.c:32: parse error beforeGLUtesselator’
esdl_glu.c:32: warning: no semicolon at end of struct or union
esdl_glu.c:34: parse error before }' esdl_glu.c:34: warning: type defaults toint’ in declaration of eglu_tessobj' esdl_glu.c:34: warning: data definition has no type or storage class esdl_glu.c: In functionesdl_combine’:
esdl_glu.c:760: eobj' undeclared (first use in this function) esdl_glu.c:760: (Each undeclared identifier is reported only once esdl_glu.c:760: for each function it appears in.) esdl_glu.c:760: invalid lvalue in assignment esdl_glu.c:761: parse error before*’
esdl_glu.c:767: datap' undeclared (first use in this function) esdl_glu.c:772: warning: left-hand operand of comma expression has no effect esdl_glu.c:775: warning: left-hand operand of comma expression has no effect esdl_glu.c:778:mycoords’ undeclared (first use in this function)
esdl_glu.c:779: `combined’ undeclared (first use in this function)
esdl_glu.c:798: case label not within a switch statement
esdl_glu.c:801: case label not within a switch statement


(mrmunkily) #4

have you tried kayosIII’s binaries?


(slikdigit) #5

I’m having a hard time with wings and linux; not sure what I’m doing wrong. It compiles -ESDL used to not compile; now it does and I don’t know why. but it runs this super flickery window that keeps on growing till I kill it.I have to admit I know nothing in Erlang, have not tested my erlang / esdl install on anything else.
I know what the detriments to erlang are: longer download, more involved install, slower performance, smaller base of qualified coders-marginalization. I won’t bash it though, since I don’t know the advantages. The Esdl page did mention the code was pretty raw and not garantueed to work properly. I’m pretty sure I could figure out a good install method- but I need to get through the mechanical spider first.


(overextrude) #6

I have been unable to locate these (I checked kayosIII’s web site), and the only reference I’ve seen to binaries involve pre-compiled DLLs for 'doze. Do you have a URL available?


(Hos) #7

I don’t know if this will work, but I’ve uploaded
my built copy of esdl:

http://bebop.cns.ualberta.ca/~cwant/esdl-built.tar.gz

Chris


(overextrude) #8

Thanks a bunch, Chris. I’ll download it and give it a try.


(Eric) #9

Wow, thanks Hos. That solved my problem too (if you remember?) :smiley: