WIP 3ds max key config

Hello Blender users,
I have used 3dsmax for many years and when I fired up blender, with 3ds max preset, I have to say that many shortcuts are incorrect. Don’t get me wrong, it’s not unusable, but works differently.
First of all, you have “click to select”-“click to move” behavior, in 3dsmax you just click and grab.
So I came up with an idea to create my own keyboard/mouse config and make it as close as possible to 3dsmax.

things I’ve added/changed from blender’s 3dsmax preset:

  • click with activate and transform on simple tweak, just like in 3dsmax click and grab
    (unfortunately I had to change border select to ctrl+tweak to make it work)

  • double click on edge to select edge loop

  • ctrl+double click on edge to extend selection with new edge loop

  • shift click to select edge ring (I cheated on this one because I used extend and toggle select)

  • right mouse button in mesh edit mode - mesh menu

  • right mouse button in object mode - object menu

  • shift+middle mouse click to set 2d/3d cursor

  • shift to snap view like in ZBrush (3ds max snaps rotation to screen space so it’s worse in max)

To use it load blender, load 3ds max preset and go to preferences, once there, switch to Input tab and import keyboard preset at the bottom.
I will keep working on it, to bring menus to UV, Sculpting and rigging. Cheers :smiley:

This is for blender 2.73

Attachments

3dsmax-G.zip (14.6 KB)

This will be more work than I though. Blender guys set keys only in 3DView, all other views have default keys set, which is disappointing. I will set them in progress as I go. Anyway I found some inconsistency as well, and at least 2 conflicts.
First that I found is Shift+E to rotate, but when in edit mesh mode Shift+E is edge crease and E is Extrude. It must be mapped to something else.
Another thing is that 3d manipulator should be drawn always on top, so when I click on it, it should not click on mesh below it. It makes impossible to do click/activate and tweak in one step, because it selects new polygon discarding old selection. I will put both, left and right mouse translation on 3d manipulator to solve it.

Update!
I-m almost there. Border selection unfortunately is set to ctrl+left mouse, to have tweak, which was removed in original preset.
lasso selection is with ctrl+right mouse.
Extrude is set to shift+drag, just like in 3dsmax, but it removes axis constraint on 3d manipulator, with left mouse button, so I suggest using right mouse button on manipulator.