[WIP]Bevel after Boolean

This is huge!
But I’d prefer a geometry agnostic behaviour in the bevel modifier.
So we could get a good boolean operation and then we could bevel the outcome as much as needed.
Or we could just bevel how much we want any topology. Even the bad ones that come from “import crazy nurbs tessellization”. (Hey Moi3d, you know what I mean?)

2 Likes

Ilya has demonstrated a new ‘non-tube’ way of offsetting but still has not uploaded something workable with it. Maybe he has something in mind however. Having proper offset cuts so that the user may produce the bridging of them and produce the beveling kind he wants is a good idea indeed.

Btw, it must not be forgotten that such kinds of operations must have a good normals managment too. Otherwise someone can not have good results. But it seems that all those are problems that can be dealt with if the offset cuts are succesfuly achieved.

Let see…

Well, all of these types of tools - BAB, Meshfusion, HardMesh, etc - expect a certain kind of clean topology. Also, they all do some form of normal transfer.

I don’t think CAD polysoup would be suitable.

2 Likes

I ran into some difficulties. When I manage to destroy them, I will post a test version

10 Likes

it’s time to go to the modifier level

2 Likes

Is it possible to make a Creating a Variable Bevel in the latest version released for 2.8?

2 Likes

Check if this might work for you, adjust the bevel weight on the edges from 0 to 1 and on the bevel modifier you need to limit it to weight and use the percentage

1 Like

4 Likes

Not at the moment.

4 Likes

Thank you for return.
A promising addon that frankly excited me, thanks for your hard work, I hope it gets a lot better soon.

The api is changed in new versions of blender.
I will not rewrite the add-on for alpha and beta, because they can change every day.
I will update only for stable releases

9 Likes

Nice is that for the 2.9 release @rodinkov_llya

Maybe this is a limitation of the addon or I do something not correct?

2.9 The developer-supported version has not been released, and version 2.9 has bugs.

to me it looks like your text mesh doesn’t have enough subdivision along depth/extrusion… maybe fixing that would help

1 Like

does this work for blender 2.9?

Yes. It works


bab_v_0_3_0_2.py (85.3 KB)

3 Likes

actually it shows a "2.8x upgrade needed " sign and doesn’t work in blender 2.90.1