[WIP] Sverchok, parametric nodes for architects

add-ons

(zeffii) #1981

use the new scale parameter in preferences:

well I don’t have a high res screen, which makes it difficult to fully experience the problem. I think this might help. if not we’ll go from there.


(Daniel Bachmann) #1982

Hi Zeffi, thanks for the fast reaction.
I updated sverchok using the update button in the UI, pressed F8 to reload and restarted Blender, then I have tested it in 2.78c and in the built from blenderbuilder with the display scaling factor. In both versions the stethoscope remains red and does not display any output anymore. Viewertext mk2 shows content. Something might be broken with the stethoscope. Does it still show results in your environment?

PS: I also tried diffenent stethoscope scale parameter settings without luck


(zeffii) #1983

you might have to delete the stethoscope from nodeview and add it back : /


(zeffii) #1984

if a node is red, check your windows console for the error message. copy it here.


(zeffii) #1985

i pushed a small update to do exception handling in the part that might be “stale” if you load older .blends (saved with older stethoscope nodes ) – but without the error you’re getting i won’t really know.


(Daniel Bachmann) #1986

Here we go, this is what I get when I have a Number Node going into the Stethoscope Node in a fresh scene. Hope it helps.

Traceback (most recent call last):
File “C:\Users\Daniel Bachmann\AppData\Roaming\Blender Foundation\Blender\2.78\scripts\addons\sverchok-master
odes ext\stethoscope_mk2.py”, line 161, in update
if not self.inputs[0].other:
File “C:\Users\Daniel Bachmann\AppData\Roaming\Blender Foundation\Blender\2.78\scripts\addons\sverchok-master
ode_tree.py”, line 75, in other
return get_other_socket(self)
File “C:\Users\Daniel Bachmann\AppData\Roaming\Blender Foundation\Blender\2.78\scripts\addons\sverchok-master\data_structure.py”, line 533, in get_other_socket
other = socket.links[0].from_socket
IndexError: tuple index out of range

location: <unknown location>:-1



(zeffii) #1987

i’ve added a rule to supress that particular message, because it’s not the one i’m interested in.

anyway, the problem here is not the current code in the Master branch, but rather the current revision of the add-on on your computer. It does not appear to be updated correctly. I propose a small script to clear some Sverchok caching (to allow you to do an update anyway…)

run this from Blender’s Text Editor .


import os
import bpy


datafiles = os.path.join(bpy.utils.user_resource('DATAFILES', path='sverchok', create=True))


if datafiles:
    A = os.path.join(datafiles, 'sv_sha_downloaded.sv')
    B = os.path.join(datafiles, 'sv_shafile.sv')


    os.remove(A)
    os.remove(B)    

then update again :slight_smile:


(Daniel Bachmann) #1988

I tested the script but it did not work. I have removed/reinstalled sverchok, after that it did recognize that it had the latest commit and did not propose to update anymore.

Then i tested the stethoscope function on two different computers with blender 2.78c installed and activated the terminal console to see the output, here is a screenshot:



(zeffii) #1989

i see… I think you need to UserPreferences->Addons->Enabled-> …Sverchok, update the stethoscope scale value, then “Save Preferences” (at the bottom), and store these sverchok preferences in your startup Blend by doing Ctrl+U.

thanks for the screenshot. (Even if the above advice doesn’t work I now understand where the error is happening)

it’s more convenient to discuss Sverchok issues on the issue tracker here : https://github.com/nortikin/sverchok/issues/1593


(zeffii) #1990

run these in the console… i’d like to see the output, i’ve added the expected results as a comment ( # ) on the lines below




[mod for mod in bpy.context.user_preferences.addons if 'sverchok' in mod.module]
# [&lt;bpy_struct, Addon("sverchok")&gt;]


import sverchok
sverchok.data_structure.SVERCHOK_NAME
# 'sverchok'


(zeffii) #1991

dbachman, if you update again it should be resolved.


(Daniel Bachmann) #1992

Hi Zeffi, here the output of the console:
>>> [mod for mod in bpy.context.user_preferences.addons if ‘sverchok’ in mod.module]
[<bpy_struct, Addon(“sverchok-master”)>]

>>> import sverchok
>>> sverchok.data_structure.SVERCHOK_NAME
‘sverchok-master’

And I tested it (SV 0.5.9.6 ccafc01)with different Stethoscope Size Settings with the following results here:





(zeffii) #1993

well… at least it’s outputting again :slight_smile:


(zeffii) #1994

can you show a screenshot of Blender’s scale settings?


(Daniel Bachmann) #1995

Thanks for your efforts, zeffi. Yeah, it is nice to see some output again :slight_smile:

Buildbot Blender Version
Display Scale = 1.0

Official Blender 2.78c, System>General>DPI = 69

Both VErsions behave the same way. Does that help or else, what exactly should I screenshot?


(zeffii) #1996

&gt;&gt;&gt; bpy.context.user_preferences.view.ui_scale


(Daniel Bachmann) #1997

Official Blender 2.78c:
Traceback (most recent call last):
File “<blender_console>”, line 1, in <module>
AttributeError: ‘UserPreferencesView’ object has no attribute ‘ui_scale’

Buildbot (Stethoscope Scale 1 | Displayscale 1):
>>> bpy.context.user_preferences.view.ui_scale
0.9583333134651184


(zeffii) #1998

you have a setting for virtual pixel mode ?


(zeffii) #1999

and this


bpy.context.user_preferences.system.virtual_pixel_mode

i need to be able to detect where this multiplier is coming from… :slight_smile:


(Daniel Bachmann) #2000

Buildbot:
>>> bpy.context.user_preferences.system.virtual_pixel_mode
Traceback (most recent call last):
File “<blender_console>”, line 1, in <module>
AttributeError: ‘UserPreferencesSystem’ object has no attribute ‘virtual_pixel_mode’

Official Blender 2.78c:
>>> bpy.context.user_preferences.system.virtual_pixel_mode
‘DOUBLE’