[WIP] Sverchok, parametric nodes for architects

Exellent, grassopher for Blender its my dreams :wink:

Nikitron, it’s great to be surprised by what people are able to bring to Blender, even better is when someone sticks with a project long enough to give others something to work with. Thanks for you dedication in working on this so long.

So, now you can download script from my site (if hosting not hanging) http://nikitron.cc.ua/blend_scripts.html
there are several scripts, i made.

Great job Alexander done, so, Alexandr Nedovzin realy author of donor-recipient Sverchok_spread addone.

Thanks a lot Nikitron and Alexander :slight_smile:

By the way, i discovered your Nikitron_scripts. Have you some example .blend files for it ? I don’t understand how it works.

Done. Look for manual on my page http://nikitron.cc.ua/blend_scripts.html

scripts looks very interesting.thanks for working on this.

For nikitron scripts fixed couple of bugs, you can install it as usual addon.
version 0.1.0

Thanks for bringing up interesting matters!

I was quite curious when i first saw your thread, even dug out Geometry nodes to play around.
What was not obvious after watching your video was from where came Object nodes, now it’s more or less clear.

Unfortunately there is an error when i try to recreate your example:

location: /home/user/BLENDER/blender-2.68-r59650-linux-glibc211-x86_64/2.68/scripts/addons/sverchok_spread.py:281
rd_cache[0] is False
Traceback (most recent call last):
  File "/home/user/BLENDER/blender-2.68-r59650-linux-glibc211-x86_64/2.68/scripts/addons/sverchok_spread.py", line 556, in execute
    if 'spreads' in per_cache[self.cache]:
KeyError: 'Surface object'

Print on line 417 is uncommented.

Could it be some changes in blender again?
This was a blend file i used http://www.pasteall.org/blend/23786

Thanks for looking into this.

PS. С русским у нас лады. :wink:

EPPO, try to run this script as addon maybe. As i understood, you ran from text area.
And this is something sometimes, that you need select active object to work.

I was running it as an addon; text was just to see what’s going on in it…
So it has a significance which object is selected when i click on Update? I’ve tried with grid and donor, same error message.

Edit: nodeitems_utils.py ? Do i have to have it? Guess, so…5397 Jun 27.

Edit 2: crash.txt , relevant part

hey man, can’t get it to work, it loads but i can’t seem to do anything with it.

I’m in OSX, 10.8.4,
using blender svn r59589

here is the error i get when i hit the “update” button

if its fast enough it might be what we were needing to ease motion graphics!!!

thanks for ur work man!!

No need to run a script in Edit mode. Run it in a mode Object mode. I checked your file is working.

Comments on the picture:

  1. the donor can only mesh
  2. to be a donor and distribution center is not possible
  3. max must be greater than zero, otherwise the changes will not see.

That was very nice, you need to set the Origin to floor of the donor-object.

@Cfyzzz: Thanks for checking the file.
Guess i saved it in this state causing confusions… Sure i was trying to Update in Obj mode. Double checked - Blender collapses leaving the same “Key not found” errors in crash.txt.

So i went back to 2.68.2 r59096 and it just works. Blender has changed once again…

Anyhow, thanks for sharing and good luck to you and nikitron!

Yes, we have older versions of blender.
Will fix as soon as possible. Additionally, blender’s nodes are developing quickly, we cannot catch :’-(

do exactly what is on video, look precisely

Nikitron_connect2objects upgrade 0.1.2 version

Here is added shift integer. So, we can shift vertices when they connect each other

Sverchok_spread updated - bugs fixed
version 0.1.2
Now it works fine. But we tested on official blender.org distros, so, you need to be sure to use official. Otherwise it’s not ours foult.