Wipe out all actions

I have a rig which is to be linked to other scene files. Someone had performed animation using the master copy, which means that the link files have issues with animating (action already present in master copy, therefore refuse to save new ones).

I have had a go at manually selecting each action ([X] icon in Action editor) but there is still something there, as I can see “Action” under the Armature in the outliner… I can’t seem to select this annoying action or delete it.

Anyone know the work around, what I have missed?

Check the NLA Editor to see if any Action has been made into an NLA strip for the Armature. As long as such a strip is still in the NLA Editor, the Action will still be linked to the Armature, even (I think – it’d be good to check this part out) if NLA is disabled for the Armature.

Also, check each Action in the Action Editor choices list to see if any have Fake User (the “F” button) enabled. If they do, and you want to delete the Action completely, then disable the F button, save the file, close Blender and reopen it – any unlinked Actions with no Fake Users should be gone from the list. But only do this if you want to completely delete the Action! If you want to just unlink it from an Armature or Object, the X button should be enough.

BTW, in the Action Editor choices list, any Actions with no users (either real links or Fake Users) should show a small circle next to their name on the list – these will be deleted when the file’s saved and reopened.

Thanks very much for your response… it was critical to solving what I needed. That Fake User animation was the issue. It’s also obtainable in the SHIFT-F4 menu under Actions.

Quite welcome. And yes, using SHIFT+F4 is very convenient if you have a large number of Actions with Fake User that need to be switched. Same for other kinds of data blocks (like Mesh and Material) that can have Fake User tags.