Wire rendered objects not showing up through ray trans?


I must be missing something, but I’m trying to have a wireframe object (rendered with “Wire” selected on the materials) show up behind a glass bottle, and it’s not appearing. Other things are, so I know my ray trans depth is sufficient. Anybody know what I’m overlooking?


um, is ZTransp turned on for the glass? I just did a quick wire cube behind a partially transparent plane and it works here (2.44). But I am not sure what raytraciing has to do with it…off or on it still looks great.

ZTransp turned on for the glass?

No, Ray Transp is. I need ray traced IOR. Ztransp and Ray Transp are either/or.

I’m pretty sure the wire rendering is a z buffer trick that only works in the final pass scanline render. That’s why you can’t have a wire material inside a shader node setup. The solid-wireframe script that creates actual geometry should sort you out though.

Ah, thanks. That sounds like the ticket.

i tried fiddling with Renderlayers for you but to no avail. BUT you could put the wired object in one scene with ZTramsp, the glass in the other scene using RayTransp, and then composite node them together, alphaundering the wire under the glass.

composite node them together, alphaundering the wire under the glass.

That wouldn’t really work because the IOR effect would be wrong. Converting the wireframe to geometry I think should do the trick though.

if that’s a script that needs documenting, I’d love a pointer to it…I don’t see it with the distro…I have a WireFrame_v1.2.py from Feb 07…

Edit Mode>Mesh>Scripts>Solid Wireframe. I’m on windoze right now in V.2.44. Don’t know about Linux cuz I’ve been stuck on this OS all day but the script is here with the official version.

it has issues…


Solid Wireframe with distro also has issues…:frowning:


Papa, Blender just don’t like you no mo! Have you tried it from XP or Linux? This render is from XP.


Worked fine for me in 2.44 with OS X.