Wireframe mode and othographic view broken?

It seems that in 2.80, if you have an object without thickness that is aligned with the view axis, it completely disappear in wireframe view/shading(?) and object mode.

I made an example with a plane and an extruded square shape. Both are clearly visible in 2.79 top and side view, but invisible (or nearly invisible) in 2.80.

I’m in object mode and wireframe mode, all objects deselected, no special setting (only the default that comes when you 1st start blender). The solid mode doesn’t help much more: for both 2.7x and 2.80 the plane is invisible on the side view and the extruded shape is invisible on the top view (hence why I used the wireframe mode on 2.7x, but now it’s unusable).

So… am I the only one affected by this? Or am I missing an obvious setting? It makes 2.80 a pain to use.

I’m testing more deeply 2.8 version and this behaviour is quite a problem for me.
it’s really difficult to work in orthographic mode.

Anyone has a solution?

It looks like problem is now, limited to object without thickness aligned on Grid and Axis.

You can try to workaround by disabling overlays. But that current situation is not great.
When you are working on ortho view, it is often to align things on Grid.

Yes, exactly. Unfortunately when I try to model houses I tend to align stuff (and make thin walls, as the house if only seen from the outside), hence my problems ^^

Disabling overlays doesn’t really fix it, in my example the “open/extruded square” is still invisible in top view. It only makes some stuff a little more visible.

To be honest I expected answers along the lines of “of course, you forgot to set this parameter here you fool!” and then it would have been automagically fixed. Darn. :smiley:

Yes. That is the kind of problem reminding that 2.8 is a beta.

Does Clement know about this problem? Has it been reported as a bug? This looks like a serious problem which should be addressed before final 2.8 is released.

1 Like

I really expected it to be a problem on my side only that I didn’t think to check the bugs. It seems to be https://developer.blender.org/T59729

I’m still seeing this problem now. Object only becomes visible in edit mode. This is bizarre to me, the bug report has even been closed as invalid. How can you consider a mesh object viewed from the perfect side as invisible?