Wireframe render ???

Hi. :smiley:
This is my first thread , so I want to say HELLO to everyone here.
I’m learning Blender for few months but I still don’t know many things.
Recently I discovered that I don’t have to duplicate objects for nice wire-frame rendering.
Maybe I missed something but I only saw tutorials with duplicating method.
I’ll try to describe my method and problem and expect that someone could answer:
is it official Blender feature or some bug in render engine.
If it’s non official , maybe it’s worth to correct and improve wire-frame feature.
If it’s official - some bug occurs. So let’s go.
I create object - sphere.
First material ( index 1 = Mat1) I set to wire-frame with Wire button then
in edit mode I create another material ( index 2 = Mat2) and assign to all faces.
After this Mat1 isn’t assigned to any face!!!
Mat2 is solid color without Wire option.
After rendering we’ll see something like picture on left.

And problem is: wire-frame is less visible on right-upper side of objects (from camera view) and it is light independent.
I tried different camera and light positions and I got always the same result.
It seems that wire-frame has offset toward left-lower corner of the screen and a little bit to camera and it’s right-upper side is covered by solid color of object ( Mat2).Always.
After that I turned on ZTransp option and set Zoffs to 0.06 on Mat1 to bring wire-frame closer to camera.
Now wire-frame looks much better but offset is still visible - a bit- picture on right.
Also now I can adjust strength of wire-frame effect by setting Alpha channel on Mat1.

Can anyone confirm and explain this behavior ??
I’ve tried this with different versions of Blender - from 2.45 to 2.48RC on WinXP and results are the same.
Blender files attached.

Attachments



GridTest_ZoffsOFF.blend (284 KB)GridTest_ZoffsON.blend (334 KB)

It’s strange - no one is interested in wire frame rendering. Or maybe it’s my bad english.
Anyway cheers :rolleyes::rolleyes::rolleyes::rolleyes:

I think no one is responding to your post because it’s not clear if you’re wanting a support request or posting this as some kind of tutorial.

I do the same thing with duplicates (the ALT-D ones) and a separate mesh that I can put on another layer to activate / deactivate as I please by enabling that layer (of course, alpha could be used in your case). I usually only have to Zoffset by 0.02 and the wire is materialed as OBJ instead of ME. I think my method has the same topright corner issues though.

How did you get two materials onto the same mesh like this?

Thanks for replay Lancer. I’ll try to make images how I’ve got this (simply by accident) but my question is about this top-right offset and possibility to make wire material as powerful and fully controllable function without duplicating objects.It might be helpful in architectural and technical renderings and especially for some animators. But it’s up to dev team. I’m just curious.

How do you render with the wires showing? Sorry if you already said it Im just not in the mood to read.

Hey,

Under the Material try clicking the Wire option.

Fort Ash

Hi.

It wasn’t my intention to post tutorial. Just asked about Blender’s behaviour. About top-right corner issue , some special meaning of material index 1 which affects other mesh materials even when is not assigned. Is it intentional or just bug. That’s my question.
But maybe it’s posted in wrong section. :slight_smile:

Here are shots with descriptions how to get wireframe without duplicating objects , step by step , for those who didn’t know.
I hope it’s clear .

http://img222.imageshack.us/img222/4376/gridtut1lv0.png

http://img222.imageshack.us/img222/1473/gridtut2ch0.png

http://img222.imageshack.us/img222/9070/gridtut3wq4.png

http://img339.imageshack.us/img339/3533/gridtut4cv4.png

Rendered without Zoffs.
http://img389.imageshack.us/img389/776/gridtutrendernozoffsdba3.jpg

Rendered with Zoffs.
http://img389.imageshack.us/img389/1995/gridtutrenderdtz9.jpg

Thanks. That looks useful. I would’ve expected the “assign” to have dropped the first material, but there you go. Looks like the problem is caused by a need for X and Y offset. Now that you have clear steps on how to reproduce, perhaps you might like to consider submitting this as a Blender bug?

Hi,
I have tried to render with wire, I’ve followed the tutorial above. The result is a transparant wireframe without colored surfaces… What did I do wrong? Can anyone help me? Thanks!!

Hi christine.
Make sure that object has two materials.Only first one must be set to wireframe with Wire button.
Second one must be assigned to mesh in Edit mode.

Thanks Jawra! You’ve solved my problem :slight_smile:

thanks Jawra! We admire you!