Wooden house - something wrong with the background


I’ve got this small wooden building here I’m working on, and the basic idea is to place the 3D model on a photo background. My problem is that there’s this small window on the left of the building, and instead of showing the photo background, it’s showing the HDRI I used to light up the scene. How could I fix this?

I’m still a newb to blender. But maybe you could disable “Transmission” in the world settings. To find in the Ray Visibility menu

Try this for your glass shader:

You’ll have to play with the color ramp settings to get the right reflections, but that should keep the alpha channel on the glass

Image with Texture used as HDR.

Special Window Glass

Composite with new background image. Use slider on add node to ajust reflection strength

Thanks for the replies, I managed to fix it!

výstavba nízkoenergetických montovaných domov a drevodomov pozemky na predaj

Výstavba drevených skeletov pre nízkoenergetické domy, montované domy, zrubové domy, víkendové zrubové chatky, záhradné altánky, pergoly, dom na klúc, chaty, drevo, skelet altánky