Working on video footage --> How to cast shadows on the floor

Hello people !

My version is Blender 2.49
I make a video of myself and a robot in the living room. The camera will not move.
The robot should cast his shadow on the floor.

I do this by creating a plane, and a spot lamp. The shadow falls on the plane and gets rendered fine.But, the plane gets rendered on the floor as well. So… lame result.

How could I make a plane that is not visible, but the shadows it receives are ?
Or some different technique, to cast shadows on the “floor” ?

I hope you understood what I am talking about and thank you in advance.


Select Shadows only in the plane materials settings


Thanks a million for your reply.

Oops! I got Blender 2.49, sorry forgot to mention that.
This is what I get for the materials, been trying hard to find something like you mention, but can not.
The “Shadow” button on the far right makes it receive shadows
The “only cast” button in the bottom middle, makes it only cast shadows, otherwise invisible. Close call, but it will not accept shadows, so no.
So neither of them is what I need :frowning:

Select ‘Only Shad’ (read the tooltips to see what the buttons do)


Crap that’s embarassing
I had clicked that before but didn’t work, apparently due to some other reason…

Thanks for putting up with me, mate