world colour vs true highlight

The sphere you see below is lit by a single sun from the left (true highlight). There is a secondary “false” highlight caused by the surface reflecting back the world colour. I want to get rid of this false highlight. The only way I have succeeded, by making the object shadeless, also gets rid of the “true” sun highlight, which I want to keep.

http://img171.imageshack.us/img171/3157/highlightsxc9.jpg

I’ve tried different settings without success. It’s a yafray render. How do I make this object stop reflecting the world colour?

Hi,

If you don’t want the sphere to reflect the world, make the sphere non-reflective by turning off raymirror on that object.

Raymirror is off. I found making it nonreflective by setting it as “shadeless” got rid of both highlights, but I want to keep the “true” highlight and only lose the “false” one.

Hi,

If raymirror is off (and you aren’t using an envmap) the object won’t reflect the world colour and the “false highlight” therefore isn’t caused by the world colour. Are you sure you haven’t got any more lights floating around the scene? What are your material settings?

Perhaps we are talking about a similar setting in a different place?
The settings I have for the material (minus various tweaks trying to make it work) are…
http://img100.imageshack.us/img100/7732/blenderpanel1dr5.th.jpg

Here you can see what I interpret as being “ray mirror” for the material is indeed off…
http://img368.imageshack.us/img368/778/blenderpanel2mc3.th.jpg

:confused: