wow factor download problems

Okay, this is really making me angry, I bought the wow factor, got all the emails and everything, and I went to my local library (because my internet sucks) to download it and the bonuses, but when I downloaded it, it gave me an error message saying:
“unable to download the_wow_factor.pdf from The data area passed to a system call is too small.” and I have NO IDEA what the heck that’s supposed to mean, and then when I tried downloading the bonuses they finished, and then I went to the place I saved them. GONE. I searched the entire computer. GONE. So Please if anyone could help, it would be greatly appreciated.:mad:

Why don’t you do the obvious thing and drop an email to Andrew (in your original email) saying that you have a problem. I’m sure he can help you out.

You might want to check with the librarian and ask if there are restrictions on downloads and/or file sizes on their computers. Many set extreme limits to prevent abuse.

Richard and retaf99 are right on.
Don’t get angry, dude.
Just work through the problem.
It’s how life is.

Yeah, I sent him an email, I just wanted to post something just for some extra help, I was trying to download it for like 3 hours at the library when I posted this so I got a litte worked up.