Wrongly looking material while following "Cave" tutorial

Hi,

this is my first message on this forum; I hope I am posting in the appropriate section.

I have recently started learning Blender by completing several short tutorials. I am now trying my hand at longer ones, such as “How to make a cave with Blender”, by Andrew Price on blenderguru (I reckon I cannot post URLs for now).

The first part of the tutorial (modeling) went well, but I am now facing issues with node-based material definition.

Here is the kind of rendering I should get:


And here is what I actually get:


I tried to scrupulously duplicate the nodes setting, and used the provided textures. I am using Blender 2.71 while the tutorial was written for Blender 2.69. Could that explain such a difference?

Would anyone be so kind as to provide me with hints as to what went wrong? Is there any way I could make my .blend available?

Regards,
Olivier.

Possible but unlikely. 2.71 is old though, we’re at 2.73a, 2.74 test build is available so a new version right behind the corner.

Too many variables. Going to guess that the object has unapplied and non-uniform scale which might have messed with UV unwrap or displacement. Object scale is on the 3D view properties (hotkey N) and it should be 1,1,1. Ctrl+A -> scale to apply. Both obviously in object mode.

My signature has link to instructions on how to prepare and upload a .blend. What it doesn’t mention is that you can delete part of the model geometry if there is a lot of it and the file size is too big. Select an area that showcases the problem in edit mode, ctrl+i to invert the selection and delete faces.

This seems like a good hint. during the course of the tutorial I actually did a first bad unwrapping due to non-uniform scale, then fixed it in the way you suggested. But it seems like I actually kept the previous, bad unwrap.

I will try to rebuild my material node by node now than I have a cleaner unwrap, and see if it matches more closely the tutorial look.

Thanks for the guesswork, JA12!