WSAG doesn't work

Hey all,

I tried WSAG… and runned a server on my computer. When I run a client at the same computer and enter ip 192.168.2.2 (if it’s not wise to give it on this site please tell me) xD, it works. But when I tried it on another computer… It doesn’t work… I tried:

  • Disabled my firewall
  • Opened a port on my computer
  • Tried the ip from myip.nl but doesn’t seem to work…
  • tried change the port in ServerMainPort.py

Anyone know what im doing wrong?

*Edit

It does work when I try it on another computer in my house.

the IP address 192.168.2.2 is a local address that is only applicable in your home network. You can’t access your computer from the internet with this IP address.

But it also doesn’t work when I use the ip from http://www.myip.nl

http://www.terrasirenum.com/blendserv/ip.php

this will tell you your external ip

if this is still not working, you may be doing something wrong with your port forwarding

I use that ip.

  • What do I need to fill in at my port forwarding
  • Does it also work when I fill in the ip from that site
  • Do I need to change the port in the blender file

Edit: Ugh… I didn’t read your post carefully enough. I see that you must already know how to do all that router config stuff, so I feel kind of silly for posting it. And I also see that you were already able to run it on the same computer as the server, so ignore what I had said about 127.0.0.1.

For port forwarding: You need to tell the router what port to forward (use the one in the WSAG file) and where to forward it (use the local IP address for your server computer, which I assume is 192.168.2.2 from your first post). You should not need to change the port in the Blender file.