WTF?? How do I have caustics??

I am using 2.48.1 32 bit on 64 bit Vista.
I rendered in BI, normal average render, no caustics, am ok render. It took a while, so I turned on render simplification (the RT next to the play button) and adjusted the settings until I got a limit of subsurf to 4, Shadow Samples at 10, and AO and SSS at .5. Sure it rendered a sh!tload faster, but WTF??? I saw something . . . are those caustics? Yes those are caustics! Accurate caustics! Fast caustics! Faster than normal rendering! WTF? Is this some kind of a joke Blender Foundation? Take a look:

Or is this some sort of those “accidental” bugs BF made?

BTW, my x and Y parts were 10x10, I doubt that has to do with anything though.

I think that’s shading, not caustics.
did you try rendering from diffrent views? like one where the water is not in the way of the ground?

Looks like distorted reflections to me, on some sort of Voronoi way.

the blotchy black dots (lots of them resulting in bright caustic-like streaks) at the bottom of pool are most likely aao artefacts due to the render simplification.


So were now on our way to learning, kinda, how to fake caustics, now for some compositor magic. :slight_smile:

another angle would help.

So is this the secret to getting decent fake caustics in BI?

If this is a bug making caustic-like patterns then maybe have it made into an option until we get photon mapping.

there is this feature in yafaray

you should look at their renderer
and you could get much better results


@Ricky: Yeah, I was using Yafaray, it’s faster, but it doesn’t give me the freedom for materials, the results also aren’t as I want em.

@All: Yeah, I did other angles, they have “caustics” too. I tried the same settings in another scene and it didn’t work. @ndy is most likely right.